8

I have a Nexus 5. It is fairly new - I bought it about 2 weeks ago.

I have previously plugged it into my Windows 7 PC and been able to access the files on it.

However, today when I plugged it in, the PC couldn't find it. Some googling and investigation found that the device driver wasn't installed - and then it said that it didn't exist.

I have downloaded the Google USB Driver from the official site. But when I told it to update/install this driver, I was told the driver didn't exist.

The LG Driver installed, but the PC still doesn't "see" the phone to let me use it as a USB.

I don't want a complicated solution. I just want to be able to get my photos off my phone and onto my computer.

3
8

Option 1:

  1. Go to device manager in Windows and delete anything having to do with your phone (LG, Google, Android etc)
  2. Plug in your phone, the drivers should install automatically

Option 2: Download Airdroid on your phone....you can transfer files over WiFi

6
  • Device Manager doesn't show ANY phone-related drivers - I can't see anything called LG, Google or Android, despite knowing some of these MUST be installed. I suspect this may be part of the problem. – openidwontworkthrowawayaccount Feb 2 '14 at 7:01
  • Went with the Airdroid option. Thank you, it let me get the photos I was after. – openidwontworkthrowawayaccount Feb 2 '14 at 7:03
  • My Nexus 5 was under "Other Devices". I right clicked on it, hit "Uninstall" and then reconnected my phone and it detected it. – Mitch Jun 28 '14 at 17:09
  • 1
    My Nexus 5 was listed as "Asus Device" in its own category. – jnnnnn Sep 7 '14 at 12:49
  • To me it was listed as "Acer Device" in its own category. [Windows 8]. – Mr_Green Nov 2 '14 at 10:07
1

go to settings then storage click the 3 dots in the top right hand corner click USB computer connection choose one of the 2 options

2
  • 1
    I'm not sure why this was downvoted. The accepted answer didn't work for me, but this answer worked great! – vanmelle Sep 4 '14 at 21:36
  • Agreed. The accepted answer did not work for me either, and furthermore, I would never advise someone to delete drivers that they can't even properly identify... all I had to do was swap from Media Device to Camera, and back again, though I suspect disabling Media Device and re-enabling it would have worked just as well. Then again, the OP only wanted to xfer files, so I guess the Airdroid solution was enough for s/he. – kayleeFrye_onDeck Dec 22 '14 at 2:20

Not the answer you're looking for? Browse other questions tagged or ask your own question.