0

I rooted my Android (HTC Desire 2.2) permanently with z4root, and it was rooted successfully. Root checker confirmed that it has been rooted. I downloaded DATA2SD, when I opened it, superuser was installed and asked me to confirm/accept root permission for DATA2SD. It was working properly.

After a few days my phone was updated from 2.2 to 2.2.2 according to my system scheduled check for update online. After updating, I realized that DATA2SD wasn't working: it says "DATA2SD cannot work without root permission"; it never asked me to accept root permission anymore.

I then checked again with root checker and it said "No root" but when I try to root it says "Your phone is already rooted, do you want to root again?" root checker says its not rooted. SuperUser is still installed, but I don't see any root permission to accept.

Any help? What should I do? I want to unroot but can't unroot.

  • OTA often removes root access. Have you tried answering the question to "root again" with "yes"? – Izzy Feb 1 '14 at 17:46
  • Yes I have.... it says "your phone is already rooted, do you want to root again'' and I answered ''yes" – chrisstals Feb 2 '14 at 8:29
  • And it just asks again, kind of circling? Ouch. – Izzy Feb 2 '14 at 12:25
  • Yea... I tried rooting with universalandroot and it says your phone is already rooted, do you want to root again? I answered yes but it says failed.... when I try rooting again or unrooting with z4root, it loads for some while and z4root closes on itself, when this happens my phone becomes slow..... – chrisstals Feb 2 '14 at 19:04
0

use framaroot to unroot it you can install the apk and run,it will show option to root it or unroot it and you can check the unroot your phone will be back to normal as you got it from factory

-1

Download SuperSU from play store and try again. Or re root your device using original method.

  • I already have superuser.... How do I root using original method? – chrisstals Feb 2 '14 at 8:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.