2

I've flashed CyanogenMod, nightly, and it is working perfectly. When I flash Gapps, then battery is drained fast, and the device is getting overheated. So, are there any solutions other than flashing Gapps, to have Google accounts on CyanogenMod?

P.S. I extracted the Gapps.zip, there was a folder named "apps" there, none of which could be installed. I tested installation using "adb", and got error related to certificate. I think by having ONLY Google Play Store, other apps can be installed, if I'm wrong, then please tell me what else is needed.

Thanks in advance

  • pretty much - google play store should let you install anything else. Might help, I suspect to give more details on your phone, cynogenmod version, and where you installed gapps from – Journeyman Geek Feb 2 '14 at 3:57
  • My phone is HTC Sensation, and I installed cm-10-20131006-NIGHTLY-pyramid and flashed gapps-jb-20121011-signed. I downloaded them from cyanogenmod's official site and goo.im. – Mostafa Shahverdy Feb 2 '14 at 4:00
2

You might wish to take a look at the NOGAPPS project at XDA. It's not yet complete, but most parts seem to be in a working order already. NOGAPPS basically is an OpenSource replacement of most Google apps (including Playstore), often mapping to free alternatives (e.g. OpenStreetMap for maps).

Side-effect: More privacy, less tracking :) But keep in mind that some components are still in Beta (Maps, Playstore) or completely missing (still under development; Login Services, Services Framework), so it's not yet a full replacement of GApps. Still it might be sufficient for many cases.

  • I'm a fan of free software, but this seems to be in its first steps :) thanks – Mostafa Shahverdy Feb 2 '14 at 14:39
1

You can try only installing the "core" Gapps apps. Choose your current Android version and select the "Gapps Core" zip. Then boot into recovery and flash it. Beforehand you have maybe to whipe your paritions in order to have a clean install.

http://goo.im/devs/BaNkS/GApps

If you want to install CM10.0 you need the Gapps files for 4.1.x

Edit other possible sources: http://forum.xda-developers.com/showthread.php?t=2548351 http://forum.xda-developers.com/showthread.php?t=1809377

  • Which there is no downloads available for 4.1.x :( – Mostafa Shahverdy Feb 2 '14 at 14:35
  • 1
    Have you checked with CyanogenMod's GApps page? It lists which GApps correspond with what CM version. // Edit: Ah, I see: they have no links for "core only" packages :( – Izzy Feb 2 '14 at 15:01
  • @Izzy Maybe I must consider compiling CyanogenMod and adding those packages by myself? – Mostafa Shahverdy Feb 2 '14 at 18:03
  • CyanogenMod does not include those packaes (for license reasons), that's why they're provided separately. I don't know where other (minimal) variants are provided, but I rawly remember having seen that. – Izzy Feb 2 '14 at 19:14
  • 1
    @MostafaShahverdy I added some more posible sources for Gapps packages with reduced bloatware. – bonanza Feb 4 '14 at 7:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.