I was trying to move GoogleMaps on SD-Cards using Link2SD. When I tried to do so I got a message stating

Link2SD could not obtain root access. if you have root access make sure you respond 'Allow' or 'Grant' to the superuser request

Then I opened SuperUser to check the application list. I was surprised to see that there were no apps there! The last time I have checked there were some apps there(Link2SD, BatteryDoctor, TerminalEmulator).

Searching through the net I read that if an app needs root access, it will ask for it. The next step was to see, SuperUser's settings/preferences.

  1. The Automatic Response is set to Prompt
  2. Notifications are ticked
  3. Notification Type is set to Status Bar
  4. Use Advanced Prompt isn't checked

Navigating through Link2SD, I've noticed that Link2SD was updated. The next thing to do was to uninstall it and install it again. The first time I run it, it never prompted me to give it root access.

What may be wrong? Is there a way to give apps root access(by "brutal force")?

  • 2
    Download Root Checker and see if you still have root. You may have lost it.
    – geffchang
    Feb 2, 2014 at 10:34
  • @geffchang: You were right! RootChecker stated that my phone wasn't rooted. How could this have happened? Is it possible to become unrooted on it's own? Now I rerooted it and it really asks for root access.
    – Thanos
    Feb 2, 2014 at 15:23
  • weird things happen. i've experienced it before too. glad you were able to fix it.
    – geffchang
    Feb 2, 2014 at 16:21

2 Answers 2


Download Root Checker and see if phone is still rooted. If it isn't rooted anymore, re-root your phone.


Install SuperSU instead of SuperUser. Worked for me!


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .