Yesterday I connected my i9000 to Kies which showed a message about the Froyo upgrade. I clicked on Firmware Upgrade, it started with an progress bar, and when it got to 100% it tried to reconnect to the phone and it again showed "Firmware available. Want to upgrade?" I clicked on upgrade again but it did not show any progress bar, just but tried to reconnect and then displayed the update message again.

Now whenever I connect the phone to Kies the "Firmware Update" link is disabled. I thought that the phone might have been successfully updated despite everything in About it still shows 2.1 update 1.

How can I fix this and update my Galaxy S to 2.2?


1 Answer 1


Make sure you have the official drivers installed from Samsung.com, then reboot your device and PC and try again. You can also try putting it into download mode before using Kies:

  1. Remove the battery
  2. Hold VolumeDown plus the Home key plus Power. While holding,
    1. Reinsert the battery.
    2. Release the power button, still holding the others, about 1 second after the white "GT-I9000" text appears.
    3. After a few seconds a yellow triangle with an android in it should appear, this is Download Mode. If it doesn't, try this again while holding Power the whole time.
  • why we need to do 1. point? and if we start download mode without kies then will it connect to internet ? Feb 23, 2011 at 5:08
  • You can't get into download mode by just doing steps 2 and 3, you have to do 1 as well. Download mode just boots your phone into a mode where it will accept firmware upgrades -- Kies normally puts your phone into that mode automatically, but sometimes it fails. So doing it manually may help. Download mode does not connect to the internet or the cell network. Feb 23, 2011 at 14:26
  • 2
    @Jeevan The easiest way to install the correct version of the drivers is to use the "Update Drivers" command within Kies when you click on the Kies logo, don't use the ones from the website, as they may not be right for your version of Kies.
    – GAThrawn
    Mar 7, 2011 at 14:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .