19

I recently changed to a newer phone and currently using my old android phone as a sort of "ipod". However, it always shows the message that there is no sim card. I know this is just an annoyance but is there anyway to disable it? I am rooted running a custom sense 4 rom on ICS. Is there anything I could flash to remove this message? Or disable the cellular radio completely?

Screenshot
Screenshot (click for larger variant)

2
  • I've tended to keep old Sim cards for just that purpose Feb 3, 2014 at 13:25
  • There are Xposed modules to remove the 'no SIM' from the status bar, but I cannot find anything to remove the HTC one from the lock screen.
    – RossC
    Feb 3, 2014 at 14:53

4 Answers 4

7

You can remove the "No SIM" notification from the Galaxy S3 S4 and Note 3 by adding an entry to your build.prop. You need root to do this.

I recommend using JRummy's Build Prop Editor. Once you've installed it, launch the app and click the bottom right icon (a + sign).

In the first box you can enter a description like so (this is optional):

# Remove "No SIM" from notification bar

In the second box, enter:

ro.config.donot_nosim= true

Then save and reboot.

If the "No SIM" popup still shows, or you get the "No SIM" notification icon, then look for an entry that reads:

ro.config.tima=1

and change that to:

ro.config.donot_nosim= true

If that still doesn't work, try removing ro.config.tima=1 or set it to 0 instead of 1.

You can also add sys.hiddenmenu.enable=1 to enable the hidden menu if it isn't already in your build.prop.

3
  • 1
    These Instructions worked for me on my Note 4.
    – cloneman
    Feb 15, 2015 at 20:28
  • 1
    Worked on my Note 2. Feb 12, 2016 at 11:28
  • This did not work on my rooted Note 3. Tried ro.config.tima=0, false, and removed entirely in every configuration with ro.config.donot_nosim=true and 1. Bummer. Wound up using an Xposed module.
    – psouza4
    Mar 26, 2016 at 19:50
5

Turn on airplane mode, enable WiFi. Problem gone.

3
  • 3
    Enabling Airplane mode (a) did not remove the SIM card persistent notification and (b) added a new persistent notification on my Note 3. Unfortunately this answer is a bust.
    – psouza4
    Mar 26, 2016 at 19:51
  • 1
    You need to restart the phone after you put it into airplane mode. When it restarts the notification will never come up, probably because it never tries to connect to the mobile network.
    – CodyF
    Mar 29, 2016 at 14:16
  • Confirmed on unrooted S5 that psouza4 is correct. Now you'll have TWO annoying icons on your status bar, and, CodyF, restarting has no effect. So, this solution is worse than unhelpful.
    – ctb
    Aug 25, 2018 at 17:29
4

If you have root access:

  • download the free "Notifications Off" app from the Play store;
  • open it;
  • scroll all the way down till you find "system ui" and uncheck it;
  • hit the little floppy disk icon at the top to save it.

This works for my Sprint Note 3 on page plus.

2
  • The app sounds nice, but won't that disable all system warnings, including potentially important ones? Dec 30, 2014 at 9:26
  • @Tobias: it will, this should not be the solution
    – psouza4
    Mar 26, 2016 at 19:49
2

Turn on Airplane Mode. It will turn off wifi unless you need wifi then I don't know what else to do.

4
  • Funny little quirk of most Android phones: You can turn on Airplane Mode and then turn on WiFi. So your cell radio and GPS stay off, but your WiFi will work. However, I don't see how this is going to help the Asker.
    – ale
    Mar 14, 2014 at 15:02
  • 1
    @Al - This is not just a quirk of Android. iPads work similar - Airplane mode still allows you to independently turn Wifi on.
    – wbogacz
    Mar 14, 2014 at 16:54
  • This is the proper solution.
    – Tobia
    May 9, 2015 at 12:09
  • 1
    As has been pointed out in a duplicate answer to this question, for at least some phones (perhaps all?), this will not help. Not only does Airplane NOT remove the no-sim-card icon & notification, but it also triggers its own airplane mode icon. This answer proved to be unhelpful.
    – ctb
    Aug 25, 2018 at 17:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .