1

I've been trying to install Cyanogenmod on my Samsung Galaxy S2 (GT-I9100), following the official guide.

I was successful in installing Clockworkmod and can enter the recovery mode. The problem starts when I try to wipe/format my sd card. It fails, saying something like "cannot mount /sdcard".

If I go to mount/storage and try to mount the sdcard I get "error mounting sdcard". And I get something similar of course if I try to "install zip from sdcard".

If I boot my phone normally I get the Samsung logo (yellow triangle included) and then it goes to black. Access to the sdcard via usb is not very consistent (screen is black so I don't know what's going on, but when I plug in the usb sometimes I can see the sdcard in my computer, sometimes not, and when I can it gets disconnected often).

Maybe it is a problem with the sd card? I wasn't having trouble before this, except maybe very slow access sometimes (which I blamed on Samsung's bloatware).

| improve this question | | | | |
0

With the information you've given, it sounds like your SD card might be damaged, or not formatted properly. Make sure the SD Card is formatted in FAT32 with a card reader if you have one available. If there isn't anything you need on the SD Card, try wiping the SD Card through CWM, and reformatting it. If this doesn't work, the card is probably physically damaged.

| improve this answer | | | | |
  • In Andriod /sdcard isn't talking about the external SD card /ext_sdcard, therefore you can't read it with a card reader (it's the internal storage). – Derek 朕會功夫 Jan 31 '15 at 10:50
0

Had the same problem when I bricked my Samsung S1. Tried to install Cyanogen 10.2.1 over Semaphore CWM. The issue was not in my internal or external SD card, but within Semaphore recovery soft (I think it was Semaphore CWM 5.0.27, downloads as Semaphore 2.7.4).

Cyanogen team recommends it and links to it from their site, but its a no go for me :( Just use another Recovery tool. For example google for Replicant recovery image. Flash that one with Heimdall instead of your previous CWM. Worked flawlessly - no "Can't mounts" or cache/data errors with it

Good luck

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.