I have rooted Samsung Galaxy S4 (Int) using CynongenMod OS. I am trying to install and run an executable file which needs its configuration file to be copied to the /system directory.

Now, after copying my files from PC to the /sdcard folder, i am unable to copy the .conf file to /system/etc and I can't also copy .exe file to /system/bin.

I know that I have to mount the /system directory. I restarted my phone and boot into Recovery Mode and then mounted /system directory, but it did not work.

I also tried mounting it manually from the adb shell using the following command:

mount -o remount wr /system/

still it is not mounting and I can't perform the copy. It shows me in the terminal the following message:

mount: Permission denied 

so please help me mounting the /system directory

migrated from stackoverflow.com Feb 3 '14 at 21:00

This question came from our site for professional and enthusiast programmers.

  • 1
    the command is mount -o remount,rw /system – user23414 Jan 28 '14 at 14:23
  • @AlexP.: It worked. Would you please put your comment as an answer, thank you – McLan Jan 28 '14 at 14:41
  • Thank you @ChrisStratton for the note, and sorry for putting off-topic question .. what do you suggest I do , should I delete the question ? – McLan Jan 28 '14 at 16:09
  • You don't need to do anything - you have your answer and the question may or may not be closed by the community. – Chris Stratton Jan 28 '14 at 16:11

The command is mount -o remount,rw /system

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.