2

I've got a Moto G with 4.4.2 and, as stock OTG functionality is broken in the latest android version, I need a way to mount my mini USB card reader (meenova) to /sdcard folder.

From what I've found on the internet I have to use this shell (I'm trying to use it with tasker):

"mount -o rw /dev/block/sdb /storage/emulated/0" or "mount -o rw -t vfat /dev/block/sdb /storage/emulated/0" Neither of them worked for me

/deb/block/sdb is the location of my sd when plugged in and /storage/emulated/0 is the phone internal memory (or at least I think so, I've also tried using just /sdcard but no luck either)

I was able to mount the sd card using Stickmount app from Chainfire but it mounts it to /sdcard/usbStorage/sda and I need it to be just /sdcard (plus if I manage to do that with tasker I don't need another app installed).

What can I do? Thanks.

  • /storage/emulated/0 most likely is already used. Try ls -l /storage/emulated/0 (or use a file manager) to check for yourself. You cannot mount another device to the same place, you need an "mpty directory" to mount it to. – Izzy Feb 3 '14 at 23:09
  • /data/local/tmp is world writeable...? – t0mm13b Feb 4 '14 at 0:10
  • Izzy, I tried with /storage/emulated/0/USB (that folder doesn't exist so it's empty) but still doesn't work, is that the way I have to do that or it has to be outside storage? And t0mm13b, /data/local/tmp has all rww permissions granted. – Carlos Feb 4 '14 at 9:41
  • Also I've tried to do that via terminal emulator and says: "Mount: Operation not permitted" – Carlos Feb 4 '14 at 13:40
  • For mount to work, the mount point needs to exist and be a directory. The directory doesn't need to be empty, but if it's not, the existing contents will be hidden once the mount completes. So you need to do mkdir -p /sdcard to create the mount point (the -p prevents an error if it already exists), then do mount /dev/block/sdb /sdcard to mount the SD card. You may need to use /dev/block/sdb1 instead. Both the mkdir and mount commands need to run as root. – Trebor Rude Feb 19 '14 at 19:38
1

It's actually real simple but you need work from recovery. All things mounted go through some script called fstab. And don't go change anything until you know sure that's right to do. Some info can be found in a map called MNT and PROC. However never try to alter those because it could lead to bricking your device.

Some textfile examples are MOUNTS and PARTITIONS where you can find detailed info. Mounting however uses the fstab folder as device parameter info point. So think adding or changing it might work. Here an fstab textline as example.

/dev/block/mmcblk0p9 /system ext4 rw

You might find more info when googling for android fstab properties. Still altering them in any way is up to you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.