1

I have installed Mavericks on my computer. Before I had Mavericks, I could plug my Android device into the USB port and it would show up in the Finder and the 'USB Debugging' display would show on the phone.

Now, when I plug in the phone, the computer acts as if the phone does not exist and the phone does not show the USB Debugging thing.

I have been developing Android Apps for two years and this issue is mind bending. I have all the necessary Developer Settings on my phone turned on. This has been tested on multiple Android devices with all different versions of Android. The problem is the computer, not Android.

Has anyone else run into this?

  • Not me. But have you checked whether the device still gets detected as USB device (on Linux, that can be done using the lsusb command – I'm not sure, but guess Mac has something similar)? If it does, are the vendor and device IDs still the same? Also, if I get it right, "have Mavericks" means you've updated your OS. Maybe you need to reconfigure something there? You don't write what Android device this is about. Please edit your question, and also include the Android version involved, and what USB mode you were using (MTP, UMS). – Izzy Feb 4 '14 at 0:33
  • Furthermore, if you're not talking about an ADB connection, USB debugging is not needed for that. Try switching it off, and see whether that helps. There were reportings where USB debugging interfered with UMS/MTP connections. – Izzy Feb 4 '14 at 0:34
  • It occurs for all Android versions and devices I can get my hands on. I have tried it with API 8 on up. We have them all here in the office. It does not show up as a USB device anywhere on the computer. Doesn't matter if I connect it as a Media Device, through ADB, or as a USB Mass Storage. – Davis Hunt Feb 4 '14 at 0:47
  • Other USB Mass Storage (e.g. standard external USB disks) showing up fine? That should be the same as an Android device in USM mode. Just to rule out general USB problems on that Mac, could you try any other USB devices you can get your hands on? – Izzy Feb 4 '14 at 6:50
  • All other USB devices work fine. Thumb drives, SD cards, iPad, iPhone. Its all problems with Android. Maybe something with the USB drivers (which I know nothing about)... – Davis Hunt Feb 4 '14 at 19:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.