1

I have a Nexus 4 with Android 4.4.2 and I can't switch off the spell checker. I write messages in several different languages and it insists on changing foreign words to the closest English. Writing a message can take me several minutes to sort out all the errors Android itself introduces.

Assessing Settings > Language & input the Spell checker field is turned off, but this doesn't stop Android from messing up my messages.

Thank you.

4

Try going into Settings > Language & Input and configure the Google Keyboard. In there you can turn off 'Auto-correction'. This should stop it from changing the foreign words to English.

You could also try adding additional dictionaries. This should allow you to enter words from different languages without it detecting them as mis-spelt English words.

0

I did Settings -> Language & Input and turned off Spell checker.

And then still in Language & Input I went into the Google Keyboard config, de-selected Use System Language, de-selected English(US), then selected Alphabet(QWERTY).

0

On HTC One M8 what I did:

Settings -> Language & keyboard -> Keyboard options -> Advanced -> Word prediction unticked.

Worked for me.

0

Android 5.1.1. Settings>Language & Input>Google Keyboard>Text Correction>Disable Auto Correction

-1

Just turn off Swiftkey and auto correction on your remaining keyboards in Settings → Language & keyboard.

  • 1
    What has Swiftkey got to do with anything? It wasn't mentioned in the question. – Dan Hulme Oct 20 '14 at 11:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.