0

(This post is a follow up of my previous one )

I managed to root and install gapps in my generic tablet, but now there is a small pending issue. When I go to Manage Apps->All, I can see some newly installed services like Google Play Services, but nothing in the menu. I have also cleared the cache from the Recovery, with no luck.

My first thought was to just get Google Play's apk from my mobile and install it to the table, but I am hesitating a little. I only care, about Play Store, the others will be retrieved from there on demand.

Has anyone encountered that before?

  • Not in that way. Could you please check whether all the .apk files from the zip are in the corresponding places on your device? Example: zip:/system/apps/vending.apk should be in /system/apps/vending.apk on your device. (background: it might well be the zip contents where flashed/unpacked incomplete). If that's the case, it should be safe to flash it again in the same way, and take care for any potential feedback/error-messages etc. – Izzy Feb 5 '14 at 21:44
  • Indeed I cant see them...also an entire folder is missing(addon.d). I will flash again – py_script Feb 6 '14 at 19:41
  • Ok, tried again, no suspicious messages during the process and still cannot find the apps in the menu. Why not install the apk of Google Play? – py_script Feb 6 '14 at 19:47
  • Because you cannot (I mean, you can, but it won't run; it must be a "system app"). OK, 3rd variant: Copy the .apk files to the corresponding directories manually. Remember for that you need to remount /system read-write. Easiest way probably is using a root-capable file manager (recommendation: ES File Explorer, which can also do the remount for you). Then remount r/o, and reboot. – Izzy Feb 6 '14 at 20:02
  • 1
    I have tried both unmount-mount and remount commands. I was unaware of that ES file explorer trick. I will take a look when back home – py_script Feb 7 '14 at 13:08
1

Usually this should be an easy task – provided you've got a custom recovery on your device. Turned out, it was not as easy in this special case, so I will list multiple options here. In combination, they finally lead to success – as one can see in the comments on the question itself.

Variant 1: Custom recovery

That's a one-liner: Put the GApps archive on your SDCard, boot into recovery, chose "Install update.zip from SDCard", and select the GApps archive. Done. After the next boot, Google Apps should be there.

Trouble in this case: No custom recovery. OK, next one.

Variant 2: Use ADB to side-load it

This variant was even figured by the OP himself. Requires ADB to be installed on your computer (see: Is there a minimal installation of ADB?), and your device setup (device drivers etc.) as well as connected via USB. For a detailed how-to, please see How to: use "adb sideload" on your Android device. Here, in short:

  1. place the GApps zip file in the directory where your ADB executable is
  2. Make sure you have USB debugging enabled in Settings → Development on your device
  3. Boot your device in recovery mode, and connect it to your PC
  4. On your device, use the volume up/down keys to select "apply update from ADB," then press power to select it
  5. On your computer, open a command prompt window and navigate to the directory from 1., then execute adb sideload <zipfile> (replacing <zipfile> with the name of your GApps file)
  6. When the installation is finished, select to "reboot" the device.

Done. Once the device finished booting, your Google Apps should be there.

Or not, as in our case. Services got installed, apps were missing. OK, let's trick the remains.

Variant #3: Doint it manually

Preparation

  • Install ES File Explorer on your device. This will help us a lot.
  • Unpack the Gapps archive into an empty directory on your SDCard. Might be an optional step, as ES File Explorer can deal with ZIPs directly, but might make things easier

Do it

Launch ES File Explorer on your device. Tap the menu button, tap "Root-Explorer" (the text, not the switch next to it – though you must make sure that's switched to "On" as well). A popup should open, where you should find a "r/w" icon (second to last entry). Tap that. This should remount your /system partition, so you can write to it.

Now use ES File Explorer to navigate to your (unpacked) GApps archive. Copy the .apk files from system/apps/ to /system/apps/ on your device. Similarly, files from data/apps/ should be copied to /data/apps/. Now back to the menu, and re-mount your /system partition read-only.

Reboot.

Now, the Google Apps should be there.

Still not? Bang. Variant 4: Get another device... or at least another ROM...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.