I live in the Netherlands and own a Samsung Galaxy S running Froyo. Last week I was in the U.S and to my surprise, I was unable to get a GPS fix there. At home I usually get a GPS fix within a minute or so, but last week, I tried multiple times to get one for 10 minutes or longer without any success. Has somebody else encountered the same problem? Is there a solution/fix, so I can prevent this from happening in the future?

  • 1
    Getting a GPS fix usually take longer if you've been moving with the phone turned off (e.g. on an plane); however 10 minutes should be sufficient. Do you have a clear view of the sky? Are you in a place with lots of tall buildings which may cause the GPS signal to bounce around? If you are in areas with high density of tall buildings, you might have better luck with Wifi positioning in addition to GPS. Turn on Wifi and 3G, and tick "Settings > Location & Security > Use wireless networks"; the 3G connection is necessary to send Wifi data to Google's server to calculate your position.
    – Lie Ryan
    Feb 23, 2011 at 13:24
  • I don't think that tall buildings blocked the signals, as I tried to get a fix in various places, inlcuding wide open areas and it didn't work. I think I had the Wifi positioning turned on but maybe this was the problem?: I had blocked data roaming... I should also mention that by now I have returned to the Netherlands and everything works fine again, so I indeed suspect that it had something to do with blocking data traffic on my phone.
    – Sebastian
    Feb 23, 2011 at 15:04

3 Answers 3


I've found the GPS Status app to be good for seeing what’s happening with the GPS sensor. It can also manually download AGPS data to improve the time to get a GPS fix.

According to the Wikipedia article on Assisted GPS, you need up to 12.5 minutes of continuous, clear signal to get a GPS fix without AGPS. It’s pure speculation on my part, but maybe your phone doesn’t download AGPS data automatically if you’re roaming and don’t have wifi.


If you have a rooted phone you can try the FasterFix app, it worked for me. You can set the continent where you are and the GPS get a lock in last than a minute.


IIRC there is a hidden menu that allows you to enable/disable automatic downloading of the GPS almanac via the data connection. Entering ##3214789650## will bring you into the GPS test mode (with Android 2.2). Check the SUPL settings. See this great blog post for more information: http://www.androidng.com/fix-galaxy-s-gps Also xda-developers has a nice topic about a simple hardware fix for better and fester GPS fixes, you can find it here.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .