9

How do I disable the popup (the one asking me if I want to mount my SD card) when I connect my phone to my PC via USB?

I've been told it's a feature of CyanogenMod but I can't for the life of me find it. I'm using CyanogenMod 7.0 RC, with Android 2.3.2.

  • What is your operating system? – Daniel A. White Feb 23 '11 at 17:17
  • @pideltajah, Is your device rooted? Also check if you ar able to access USB storage option from your device. – xavier_fakerat Mar 23 '17 at 19:40
  • 1
    Adding a screen shot would help. The original question is for Android 2.3.2 and you are on 6.0. You can include the screen shot in comments – beeshyams Mar 24 '17 at 1:43
  • My device is not rooted. Here's a screenshot: imgur.com/OK5W1MC – Stack Underflow Mar 28 '17 at 17:11
  • Remove the PIN access to remove the dialog. It's a security thing. – Device Guru Dec 18 '18 at 14:56
5

If you enable USB debugging in the Developer options, the phone's "USB Connected!" screen doesn't popup anymore :)

  • 1
    That depends on the phone... – Liam W Dec 11 '12 at 10:56
  • 2
    Does not help. That's what I did a long time ago. – Zdenek Aug 4 '16 at 16:58
4

Not a CyanogenMod user, but have you checked under Settings -> About Phone -> USB Settings, or Settings -> Wireless and network -> USB Settings?

  • Additionally, Settings -> Applications -> USB Settings. Some phones really have it under Wireless? Weird. – Matthew Read Feb 23 '11 at 16:42
  • Yeah, I thought that was weird, but some do according to this answer (I guess it might be to do with USB tethering?): android.stackexchange.com/questions/6238/… – Martin Feb 23 '11 at 16:50
  • I think in CyanogenMod, it is under Settings -> Applications -> Development. But it has been a long time since I've had a device that supported CM... I wish I could run CM. – Ryan Conrad Feb 23 '11 at 17:41
  • 1
    I've already gone through every setting I can find, with no luck. "Settings -> About Phone -> USB Settings" doesn't exist, "Settings -> Wireless and network -> USB Settings" doesn't exist, and "Settings -> Applications -> USB Settings" doesn't exist. "Settings -> Applications -> Development" only has the following options: USB debugging, stay awake, allow mock locations, stop app via long press, device hostname. – crdx Feb 24 '11 at 11:06
  • This is probably something that they will remove then as I don't remember it in previous versions of CM. After they started working with the gingerbread sources from AOSP, they have not yet merged in all the previous modifications, like removing that popup. – Ryan Conrad Mar 2 '11 at 17:05
2
+50

It certainly looks like, Google has disabled USB Mass storage option for most recent Android versions as you probably have noticed, do not allow you to mount SD Card / storage partition as USB Mass Storage (UMS) when plugging it to a computer.

Given that you are rooted, you can try the following resoltuions:

  1. Using terminal to mount mass storage

su

setprop persist.sys.usb.config mass_storage,adb
reboot

If you want to go back to MTP, open terminal emulator and enter:

su
setprop persist.sys.usb.config mtp,adb
reboot

su setprop sys.usb.config mtp,adb reboot

  1. Activate auto-mount when USB debugging is enabled.

As previously mentioned, when USB debugging is enabled the sd card will automatically mount when connected to the computer provided the drivers were installed correctly.

Thus you will not get persistent notifications about sd card monting

  1. Using QtADB

QtADB is a full-featured tool (designed for windows )and has a plethora of features to manage your droid. Some of these include:

  • File manager (copying files and dirs between phone and computer, delete , creation of dirs)

  • App manager (installing, removing, creating backs ups etc)

  • Shell and more..

The essence of this is that it alows mounting of external sd card to a computer without giving annoying notifications. Check here for more info: QtADB

  1. Using USB MASS STORAGE Enabler (root)

This is one of the few apps offering to restore the lost Universal Mass Storage (UMS) option.

  1. After downloading the tool ,connect your device using USB cable to your computer.

  2. Open the ‘UMS Enabler’ app and press ‘Enable Mass Storage’. Remember, give the app root access if it asks.

At this point, you might get various messages by the app, for instance, there a message asking you to set SELinux – a Linux module Android uses to make it more secure – to permissive state; this is required for the app to run properly

Credits

  1. Any way to get USB Mass Storage instead of MTP?
  2. How To Mount Android Device As USB Mass Storage (UMS)?
  3. QtADB for android
  • "As previously when USB debugging is enabled the sd cardd will automatically mount when connected to the computer provided the drivers were installed correctly." Maybe for some devices but for me, this is incorrect. I have debugging enabled and can easily mount but still get annoying notification pop ups every single time I plug in. – Stack Underflow Mar 28 '17 at 16:57
  • @pideltajah really? I reckon this is something to do with android version, because I never get any of these notification (android 4.3). Let me look into it – xavier_fakerat Mar 28 '17 at 17:02
  • Yes. I noticed someone previously mentioned this but I guess it just depends on the particular device. Thank you! Also, I added a comment to the OP question with a link to a screen shot. I'm not sure how a screen shot would be helpful but @beeshyams seemed to think that it might be. – Stack Underflow Mar 28 '17 at 17:15
  • I just perfomed the tests now. I inserted USB and switched to USB Storage option, there was no notification and when I use PC mode (HiSuite) it tuns with USB debugging enabled and again no notifications and if I disable USB debugging it automatically goes to Charging mode with no notifications) I will perfom again with another android 6 device (samsung) I will let you know the results – xavier_fakerat Mar 28 '17 at 17:19
  • @pideltajah: update Tested today with Samsung Note 4 (android 6), I don't seem to see your described notification, even with USB debugging diasabled. Only difference with and 4.3 is that only options are MTP and Camera, I am beginning to feel it might be security featured locked in your particular ROM, otherwise I have no conclusive facts other than these ones. – xavier_fakerat Mar 29 '17 at 18:19
1

If you want to disable all notifications that pop up when you connect your USB cable go to the "menu" then "notifications" then touch "usb connection" then change the settings to "Charge only"

  • 1
    It doesn't change this behavior. Plus I still want the MTP to work. I just don't want to be asked about it. – Zdenek Aug 4 '16 at 17:00
-2

It's usually under Settings -> Applications -> Development -> USB debugging

  • 1
    I'm talking about the dialog that appears asking me if I want to mount my SD card, which is unrelated to USB debugging. – crdx Jun 22 '11 at 5:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.