2

This started happening a few days ago but my phone stopped to play music (pausing) on headphones when I:

  1. Screen off
  2. Notification menu is pulled down
  3. Opening all applications on the default stock launcher

Music plays only if the music app is in foreground or if I went to the launcher and not selected anything.

I am using custom rom but it stopped working on it after using it for over a month. I tried to update the rom to a newer one but it still doesn't work.

Music plays fine when not using headphones and just using the speakers.

Phone: Note2 ROM: temasek cm11 (http://forum.xda-developers.com/showthread.php?t=2596887)

Kernel: Devil's kernel (http://forum.xda-developers.com/showthread.php?t=2239453)

App: Apollo and Google music (same thing), pretty much every music application on Android

  • I had the same issue on my phone. Seems to be related to the launcher. This seems to be a KK Note 2 related issue. – Zlatty Mar 28 '14 at 18:14
  • I solved mine with a new faster sdcard. – Tom Brito Mar 16 '16 at 16:49
1

Are your headphones defective or have a weak spot? You can try a couple of things, such as testing this on another Android device.

It could potentially be the ROM and its ability to detect headphones properly while doing different things (Multi-tasking in a sort of sense).

What you can do is go into Settings and turned Motion off. Sometimes it can sense movement and such and it'll pause accordingly. I'll look into this more but into l your next response, this is what I have to say.

Update

It is probably an Android 4.2.2 issue. You can downgrade, wait for an upgrade or perhaps install the 4.3 KitKat ROM.

Other options are trying newer/older versions of the Google Play Music software.

  • 3
    So after I played around with it, apparently it's 4.4.2 that has issues. I tried many variants of 4.4.2 on Android. I switched back to 4.3.2 and it was fine, I guess i will have to downgrade. :\ – user654628 Feb 10 '14 at 5:21
  • Now that you mention it, I most certainly agree. I remember having the same Google Play Music issues. You just reminded me. And perhaps you can wait for an upgrade? I know there are 4.3 KitKat ROMS it you're interested. – Mike Wentworth Feb 10 '14 at 13:36
1

I guess you use GEL? If so, it's because of it listening to "Ok Google". Turn off "Hotword detection" in GEL Voice settings and you'll be fine.

  • Well it fails to work in any other app and the notification menu and I was using stock 4.4.2 android, I don't think that was the issue. – user654628 Feb 12 '14 at 18:59
0

The problem seems to be related to a conflict between voice search from lock screen and music being played from locked screen. For me the following worked on Android 4.4.4 (tried and tested on OmniRom and CyanogenMod):

Go to Google Now | Settings | Voice | Select "Ok Google Detection"
Uncheck "From lock screen"
-1

Disabling Google hotword detection fixes this issue in 4.4.4.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.