0

The other day out of the blue my Wi-Fi stopped working. I've tried fixes I found here in stack exchange (see below), but nothing seems to work. How can I tell if it's a hardware problem or a software problem?

I should note that the Wi-Fi says it's on but dose not show any SSID's and my network history's are no longer there. I have tried...

  • deleting the data/misc/WiFi folder the rebooting
  • Fxr fix and rescue

I have a sprint galaxy S3 rooted running Cyan fox 2.02 (KitKat 4.4.2)

8
  • Welcome to the Android Enthusiasts! What are the "fixes" you've tried? If you don't want to get the same stuff recommended, it might be helpful to edit your question and include those details ;)
    – Izzy
    Feb 10 '14 at 7:30
  • Thanks for the update! I've just applied some formatting to make it more obvious. Have to pass the answer to someone else, though. Just one more thing: Did the "out of the blue" go together with some app you've installed/updated? Not that I've heard of such side-effects, but that's usually one the first things suspected.
    – Izzy
    Feb 10 '14 at 7:57
  • Actually i did install and un install this app ---> play.google.com/store/apps/details?id=com.easy.battery.saver around the time i noticed that Wi-Fi was gone
    – Robotlogic
    Feb 10 '14 at 8:17
  • Try booting your device in safe-mode and see whether your problem persists. Contact the author of that app and ask him for advice; it might be connected (some "optimizing" might have stuck though the app was uninstalled).
    – Izzy
    Feb 10 '14 at 9:06
  • Now we are getting somewhere it works fine in safe mode.....so hardware isn't the issue
    – Robotlogic
    Feb 10 '14 at 10:34
1

This can have multiple reasons. First thing to look for is always whether a "user app" might have caused this. This can be done by booting into : if everything works here, at least the hardware is fine, and the system as well. In that case, next steps would be:

  • Boot into , and clear (wipe) cache. This is possible on rooted and unrooted devices, each recovery (stock or custom) should permit this (exceptions are quite rare). Then reboot, and see if the issue is solved.
  • If it's not solved, and your device is equipped with a custom recovery: Again boot into recovery, this time wipe the "Dalvik Cache". Reboot, and check whether the issue is solved now.

If none of these two steps brought you any relief, you need to go the "hard way":

  • Backup all your apps into single backups (so you can restore them separate), including .apk and data. Useful tools for that: adb backup (see: , ) and Helium Backup, or on rooted devices also Titanium Backup.
  • Uninstall apps in reverse order of their installation (the culprit it's more likely an app you've installed lately, than an app you've installed a year ago) one-by-one, and after each single uninstall see whether the problem solved. Doesn't hurt to reboot as well (i.e. uninstall→reboot→check, next).
  • At the point where it starts working again, re-install all apps you've removed (again one-by-one), skipping the last one – as that was most likely causing the issue.

If the issue still persists (or still persisted in safe-mode), last resort is a . Before doing that, make sure your contacts etc. are either synced with your Google account, or backed up otherwise (the apps you have already "secured" with above steps). Does the issue stay even after this, it's most likely a hardware issue, and you'll have to turn in your device for service.

If, on the other hand, the factory-reset made it working again, carefully restore from your backups – again one by one, with a reboot in between (to make sure you don't end up where you've started).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.