4

My Galaxy S2 has recently died completely over night. It does not turn on regardless of which combination of buttons I try and how long I press them. I've tried with two different batteries, without a battery, SIM, no SIM and so on. It still seems to recharge the battery as it builds up heat when connected to a charger in the top left corner below the display side camera.

Since I'm certain it is beyond repair I've ordered a new phone and am now thinking about how to get to the stuff that was not on the SD card of the broken one, which I neglected to backup for a few month. I've been thinking about removing the memory device physically. No harm done if I break anything else as I consider it broken already anyway. Unfortunately, there are hardly any resources on the internet that I was able to find in that regard.

So my question is simple: where is the internal memory in the S2 and how can I rip it out?

I don't care if I break any other components as long as I get to that memory device.

  • 1
    Ask one of the major data recovery companies. – Reinstate Monica - M. Schröder Feb 11 '14 at 11:14
  • uhhh dismantle the board, need a steady hand with solder... that is an unusual question... – t0mm13b Feb 11 '14 at 19:36
  • I was not aware it would be that complex. I might give it a try if everything else fails. Did get a new phone by now, and will try with repair companies first. But opening it up is not out of the question, especially after I'm sure I can't break it any further. – simbabque Feb 11 '14 at 20:42
7

This may not be as easy as you think. The eMMC is connected to the board with a Ball Grid Array (BGA) connection, which is pretty difficult to reconnect once removed.

You can see photos of the chip and more discussion on the topic on this XDA post.

As for where the chip is, you might be able to find it on some teardowns, but my eyes didn't catch it in iFixIts photos.

  • Oh, if it's a BGA, then my answer isn't quite right: you need an oven to desolder it, not an iron. – Dan Hulme Feb 10 '14 at 10:08
5

It's a chip soldered to the main board in the phone. You can only remove it by desoldering it from the board in a soldering oven. (This is a precisely temperature-controlled device: a kitchen oven won't do.)

Even if you did manage to desolder it safely, the chip itself isn't a lot of use to you. Because it's an internal component, it doesn't fit into a standard reader like an SD card does, so you'd have to either try to solder it into a different phone (which might still not work, if anything on the chip is specific to the old phone), or find the specs and build a new board to fit it.

1

Were you trying to root you phone or install a new ROM on it? It could be possible that if you just plug in the logic board of your old phone into power from an old working Galaxy S2 it might just boot up. If it died overnight without you doing virtually anything to it my guess is that the battery within the phone fails to provide power through the phone i.e the internal circuitry on the power supply which is in the lower section of the phone may not be working. I had similar issues once, mine just magically started working after a month. It was a case of water damage though. If you did try to install a new ROM on the phone it may be bricked and a USB jig might help fix it. They are easily available from eBay or Amazon if you live in the US and are quite easy to make at home as well. You may also try purchasing a new USB MHL board from eBay. Replacement are available for as less at 5$. As onik mentioned, the BGA will be nearly impossible to take out and use yourself. Aftermarket data recovery companies might be able to help though.

  • Thanks for your reply. I did not do anything at all. It just went black. When I took out the battery, put it back in and turned it on, it froze while booting (the stock firmware). It has been dead since. I tried two batteries and several chargers. I also tried a USB jig already. Nothing worked and I have since proclaimed it dead. – simbabque Mar 3 '14 at 9:34
  • It might be your USB MHL board then. I cannot seem to see a logical reason behind the phone failing as long as all the parts are working correct. Did you try plugging in the battery in another port to check if it had actually charged? It seems that the internal power supply went bad. My concern for this is simply because getting the BGA data recovered will be too expensive for you and nearly impossible to do at home without the required tools. – Aditya Somani Mar 3 '14 at 9:49
  • I've actually not tried someone else's battery, and I have not put mine in someone else's phone. We were afraid either might damage the other person's stuff because the problem could be with my phone, or with the batteries. But I will try that. I might find someone who has a dedicated battery charger, too. – simbabque Mar 3 '14 at 9:52
  • Give it a shot and let us know. Maybe we can provide you more help on the same. I have the same phone too. Cheers! – Aditya Somani Mar 5 '14 at 0:41
  • Tried someone else's fully charged battery - no effect. Seems dead. Thanks for all the good suggestions. – simbabque Mar 5 '14 at 7:29
-1

Have you tried this? If not and you are not familiar with electronics, get someone to help you out http://com.odroid.com/sigong/blog/blog_list.php?bid=139

Works for me...

  • 1
    You should at least summarize the link's contents in your answer, because if the page moves or changes, your answer is worthless. – onik May 9 '14 at 12:45
  • Not only then. If the firewall/proxy blocks it, it makes no sense either. – Izzy May 9 '14 at 14:24

protected by Community Aug 28 '14 at 12:49

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.