0

I activated the Android Runtime (ART) instead of Dalvik and after that my phone rebooted but it seems that it's stuck in a bootloop.

Will the first bot after choosing ART take some extra time? How can I tell if it's stuck in a bootloop rather than just booting slowly?

My device is an HTC Explorer running CM 11 beta 4 build.

1

The first boot after swapping to ART generally takes a little longer to boot. After that it then recompiles every app using the new runtime before you can actually use the device. During this stage the device actually displays a message with it's current progress. If it never gets to that stage then there is a decent chance that Android is stuck trying to boot.

If it's stuck in a bootloop, you should see your phone continually swap from the HTC boot logo to the CM boot logo and back again. If it's stuck on just the CM boot logo then there is a chance that it is actually booting and just taking a long time.

| improve this answer | |
  • it's stuck in CM logo but – user202476 Feb 11 '14 at 3:00
1

Follow the steps below:

  1. adb pull /data/property/persist.sys.dalvik.vm.lib
  2. Open the file and replace the libart.so with libdvm.so.
  3. adb push persist.sys.dalvik.vm.lib /data/property/.
  4. Reboot your device.

Source: Phone in boot loop after turning on ART (didn't completely uninstall XPosed).

| improve this answer | |
  • 1
    Not everyone can understand these commands. Please mention (edit) what each of these steps does and the reason they should be followed. That said, this does not answers this : How can I tell if it's stuck in a bootloop rather than just booting slowly? Not to mention, the answer assumes that adb is already enabled in Developer Settings which OP didn't mention at all. – Firelord May 5 '15 at 2:27
  • @Firelord You should understand this if you tried to change Dalvik to ART in the first place. – Pavlus Aug 15 '17 at 17:18
0

I'm not using your device but doing a quick search i found this:

Before using ART, you have to enable expanding memory in Settings -> Extras!

You might want to do that before enabling ART next time. You can get more infos on here

| improve this answer | |
0

Try draining the battery, then put it on a charger and try to boot. The same thing happened here on a Motorola Moto G 2nd generation.

| improve this answer | |
0

I did the same thing. As the memory space was less in my Moto e, it went to boot loop. First it showed around 169 apps installation figure but after completing that it showed lower nos. in successive boots. After a while when I rebooted it forcefully many times, it started but now with lesser space remaining than Dalvik.

| improve this answer | |
0

I know that this thread is old, but this may help others in the same situation. My mobile is a LG G2 Mini (D618) rooted with Kingo. After I changed it from Dalvik to ART, it took a long time to reboot, while optimizing all the apps. But then, when the UI showed up, I couldn't do anything because several error messages appeared in sequence. After a while touching OK for each message, the mobile would reboot and start it all over again. In fact it rebooted even if left alone.

I re-flashed it with the stock ROM (with the no-data-loss option) but nothing changed other than it becoming unrooted again. Also tried to access it with an ADB Shell but I kept getting an authorization error. Then, after rebooting it around 30 times, it reverted back to Dalvik by itself, and everything was fine again!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.