1

A few months ago I rooted my android phone which went all fine. I then accidently uninstalled my operating system. Finally I managed to flash omniROM on my device which was as good as it got for me. The only problem is that I am not rooted anymore. My boot loader is unlocked but no root. When I run the usual commands on my computer (Mac) it just says access denied at the finish. Any help would be greatly appreciated. Thanks.

Also when I go on root checker on my phone it says. ACCESS DENIED. not rooted properly

1

You should be able to download the latest SuperSU from Chainfire and push it to your SD card and reboot into recovery mode -> install zip from SD -> select SuperSU.zip and it should install the SU binaries. You should be good from there.

  • everyone is suggesting that therse must be a custom recovery installed before installing su binary. but i want to root so that i can take a backup of the stock(original) recovey. i dont want to install the custome recovery. is there any way if we can root the device without installing custom TWRP – Abdul Mohsin Mar 6 at 6:41
  • I tried installing the su binary from the stock recovery, it says, installation failed :( – Abdul Mohsin Mar 6 at 6:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.