1

I'm sure this one is just a PEBKAC error, so please bear with me since I am new to Android.

I've uploaded all of my music to Google Play Music and I can see all of my songs via their web interface. However, on my Moto X, there's at least one song missing. I have tried refreshing the Google Play app on the phone to no avail. I haven't had time yet to go through all of my hundreds of albums to see if any others are missing songs, as well. Any thoughts?

0

Did you use the "Refresh" option in the google play music app? You can find it in the action bar menu. Another possibility is a wrong file type. Here is a list of supported file types: https://support.google.com/googleplay/answer/1100462?hl=en

  • 1
    Yes, as I stated in my question, I have tried refreshing several times in the app without success. In addition, all of the songs on the album were ripped to MP3 from the CD with the exact same settings. Besides, if it weren't a compatible file type, it would never have been uploaded to Google Play Music at all. I can find and play the song via the web interface; just not from the Android app interface. – Sturm Feb 11 '14 at 22:12
  • And I even tried a quick fix: I removed the album from Google Music, redirected the Music Manager to scan a different folder, then redirected it back again to my iTunes library so that it could re-scan my music and upload that album again. I figured something went wrong during the initial upload, see, and having it re-upload that album might help. Get this: The song that was previously missing is now there, but another song in that album is now missing from my Moto X! What gives!? – Sturm Feb 12 '14 at 5:30
  • Strange! Exceeded the limit of "20000 songs"? – thomasb Feb 12 '14 at 8:25
  • Less than half of that. – Sturm Feb 12 '14 at 15:02
  • Okay, tried another refresh, and for some odd reason, it works today. No idea why it didn't work yesterday. Thanks for the help, @thomasb. – Sturm Feb 12 '14 at 15:07
0

I think the sad but true answer is that sometimes, it just takes time. I've seen the album show up within a minute or so, but I've also had occasions where I've waited over 15 minutes, even rebooting my phone, without getting the new uploads to show up. In that case, I went to bed and the uploads were there the next morning.

I'm guessing there's something on Google's side separating the web player from the Android player, and that the sync between those nodes take different amount of time depending on when you do it.

If it still hasn't showed up in 24 hours, I would try and create a ticket with Google, but for most people, you just need patience.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.