0

The phone is a sony xperia V with android 4.1.2.

I have some contacts from my old phones imported trough google, next to that is my business contacts who are all from our company exchange system. Creating a new contact under my exchange account works well, that contact will sync nicely and show up in outlook within a few short minutes, but the contacts that I've imported from my google account will not sync. I tried to "cheese it" by backing the contacts up on the SD card, and then import them back in under the exchange account, but they will still not sync. I've toasted all my knowledge as well as google for answers, but no dice. I've also attempted to see if a recreation of the exchange account would do anything, but no.

I do suspect that either there is something with the contacts, or there is something with the exchange client on the phone, but I have no clue how to test this properly. While I did try to set the scenario on my samsung galaxy SIII, the results came out the same. Newly added contacts sync, imported contacts do not.

So my pleas ask for a hero who can give me a final answer to this mysterious behavior, so that I can finally put this silly issue behind me...

EDIT: The contacts are listed as exchange contacts after import. All sync options are on, and I've even performed a forced sync to make sure that the phone had actually synced after the importing of the contacts. Imported contacts will still not sync towards the exchange server.

  • Can you export the contacts as a vCard, email them to yourself and import to Outlook on a PC? Since new contacts sync OK, this could be a one-time operation. – onik Feb 13 '14 at 8:46
  • I see your point but for some strange reason, importing the contacts trough a vCard file does not seem to work, they do not show up... And yes, I did google it to see if it was done correctly. I will dig into it a bit more, of course, but I still would like an answer to my primary question. – Sharain Feb 13 '14 at 11:08
  • Found out I had to run the vCard trough gmail to "convert it" to a CSV file. Now the contacts show up, but... they are all "blank", listed as "name not available". I remember now that I've encountered this issue before, did not really find a straight up solution to it then either. – Sharain Feb 13 '14 at 13:45
  • Did you specifically export them as "Outlook CSV"? Google contacts also offers "Google CSV" as an export possibility, and has different headers and field order for the details of the contacts. Outlook looks for fields such as First Name,Middle Name,Last Name,Title,Suffix,Initials... whereas Google CSV contains Name,Given Name,Additional Name,Family Name,Yomi Name,Given Name Yomi... – onik Feb 13 '14 at 14:07
  • Yes, I made sure that it was to an outlook CSV file. I've actually tried all the options, just to be 100% sure that I did not leave anything untried, but nothing granted a positive result. – Sharain Feb 14 '14 at 9:58
0

Is Contact syncing enabled in Settings/(accounts)/Corporate/(your exchange account)?

View one of the contacts and go to menu/edit. At the very top, does it show that it is attached to the exchange account or the Google account? If it is the Google account, you need to make sure to select the exchange account when adding the contacts. If it does show the exchange account and syncing is enabled, edit your comment to reflect this for further support.

  • I've added the information you requested to my initial question. I will also quote myself: "I've toasted all my knowledge as well as google for answers, but no dice. I've also attempted to see if a recreation of the exchange account would do anything, but no." I work with IT-support, so you can go full on technical with me if you want. Tho this issue has left me completely blank... – Sharain Feb 13 '14 at 8:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.