0

I just bought Nexus 7 (2013) and an OTG cable. I wanted to connect a flash drive to it. When I connected it, nothing happened.

I tried to find the folder with my flash drive contents in /etc - there was nothing about my flash drive. I searched in /storage/emulated/0 - there were contents of my internal SDcard. I downloaded some applications from Google Play (e.g. Nexus Media Importer, OTG disc manager). It worked, but only for reading.

Is there a way to write to my flash drive? Please notice that I DON'T want to ROOT. (And sorry for my poor English)

1

Unfortunately, root is required to be able to write to flash drives using USB OTG on the Nexus 7. You can only read files without root.

0

You need to root your phone for using flash drive. After rooting, use Super SU binaries and stickmount app. Now you can easily use your flash drive. It will be mounted in your root directory

0

Either root your nexus 7 and follow as per the other answers(i.e. use the stick mount application). To root go to this http://m.blog.laptopmag.com/how-to-root-the-nexus-7-2013. Don't do this if you don't know about rooting, you may brick or destroy the tablet for good.

Or the safest way buy Nexus Media Importer application from the Google play store.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.