2

I'm trying to set up remote debugging on my brand new LG G2 phone.

Seen here: http://www.html5rocks.com/en/tutorials/developertools/mobile/

So far, I've:

  1. Enabled developer options
  2. Enabled "USB debugging" on the Developer options screen
  3. On the "PC Connections" screen - I've set "USB connection method" to "PC Software"

So - everything looks good at this point.

However, as soon as I connect the device to my PC, the "USB debugging" setting on the "Developer options" screen turns gray (disabled). If I go to DevTools on Chrome on my PC (chrome://inspect/#devices) and check "Discover USB devices", my phone is not listed.

What else do I need to do?

  • Installed the correct drivers (Windows) / adjusted the configuration of your computer (Linux/Mac) accordingly? Without that, your computer will not be able to recognize the device. – Izzy Feb 13 '14 at 17:53
2

I had the same problem with my G2 D802 only mine did work before when still running android 4.2. It was a driver issue and fixed it by the folowing steps:

My usb setting is set at (MTP)

That did it for me.

4

The PC Software setting is just for installing and using the LG PC software. Once your drivers are installed, enable USB Debugging, plug it in, change it from "charge only" to "MTP" and USB Debugging should work.

  • Thanks for your help. I followed all the steps in this video to install the drivers: youtube.com/watch?v=Ltd2bfCpMB4. However - as soon as I connect the device, the "USB debugging" option within the "Developer options" screen (which is checked) grays out. (It's not gray before I connect). In other words - it's as though connecting the device causes the option to disable. Any idea why? – mattstuehler Feb 13 '14 at 20:39
  • Did you change the connection mode to MTP? "Charge Only" & "PC Software" will disable USB Debugging. – abqnm Feb 13 '14 at 20:42
  • No problem. Glad to help. – abqnm Feb 13 '14 at 21:22
  • Had the same issue with LG G5... I had to install the CORRECT original drivers and afterwards be sure to use MTP connection (Media Transfer Protocol). Only after reading this answer I got the second point. – DavidTaubmann Oct 15 '16 at 22:43

protected by Community Aug 26 '14 at 17:12

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.