0

My S3 has been displaying the wrong time lately; maybe 3 or 4 times in the last week. It's not off by exactly an hour, so I know it's not a timezone or daylight-saving-time issue. It's usually off by 15 to 25 minutes; just enough to make me late to work.

It's not only a 3rd-party app or widget issue; the actual phone time is wrong (in the upper, right-hand corner near the signal indicator).

My wife has an older Samsung Galaxy Nexus, and this never happens on her phone. We live together (obviously), so our phones are in the same location, and we use the same provider; so I don't think it's a network/signal/tower issue.

Any ideas what would cause this. I've searched around, and all I can find are forums w/ 6 pages of "Me too" responses. A couple definitive answers/suggestions would be welcome.

UPDATE - I've disabled the automatic date/time settings, but the problem still comes back. I've worked on desktops and laptops for years, and they all use a CMOS battery to keep track of time... even when a computer is off. Do phones have anything similar?

1

Does this happen at a particular location? Do you have the setting as "Automatic date and time", or "Network provided time"? If you do, I assume the cellular region has incorrectly set time and is providing it wrong. The phone adjusts when you move to a well-maintained region.

| improve this answer | |
  • I'll have to check the time setting in a bit. As far as cellular region... I updated my question, because my wife and I are both on Verizon, and she never has this issue w/ her older Samsung Galaxy Nexus phone, so I doubt it's a network/tower issue. – WEFX Feb 14 '14 at 15:10
0

To further wbogacz's response, I would disable the automatic network time and just set it manually. See if that works. It worked for my coworker who was having the same issue. It isn't a fix for the underlying issue, but it did eliminate the problem, or so it would seem. It hasn't happened again in the week since he disabled the network time setting.

| improve this answer | |
  • This worked temporarily, after I manually set the time. However, a few days later, it was a few minutes behind again. I'm disabling Automatic Timezone as well just to see if that helps. – WEFX Feb 18 '14 at 18:44
  • Nope, no luck here. Any other ideas? Do phones have something like a separate CMOS battery (like computers)? – WEFX Feb 21 '14 at 15:09
  • No they don't have a separate battery. Considering the number of times I have seen this since the 4.3 update, makes me think it is a bug with the ROM itself. You are on the 4.3 update, right? If so, have you done a factory reset since you got the update? It fixes all sorts of problems and is nearly essential. If you haven't, you should look into it. Back up everything you need to your PC like internal storage. If you need more than that like contacts you can use Kies to back it up. Then do a factory reset, reinstall your apps and move your data back and see if it helps. – abqnm Feb 21 '14 at 15:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.