I have Samsung S4 Mini phone which I bought about 10 months ago. I used to transfer my files from phone to my PC and vice versa without any trouble using the USB cable. Recently, I enabled the Developer Settings (by tapping the build number 7 times), turned on USB debugging mode. I could transfer files even after this.

After a few days, my PC stopped recognizing the USB. I don't see the the USB button in the notification panel. I get a notification - "The last USB device you connected to this computer malfunctioned, and Windows does not recognize it".

In the device manager, I find Other Devices under which I see "Unknown Device". If I disconnect my phone, I don't see this entry.

I had searched quite a lot on Google for the same, but couldn't come up with a resolution. In fact, I did factory reset as my last attempt on my own and still couldn't find any result. (Lost all my apps for no reason).

Other Details: 1. I tried connecting my friend's phone onto my PC with the same cable, his device was recognized. 2. And yes, the cable was provided by Samsung itself, which used to work in the past and now it is not working.

Some one, please help me in connecting my phone to laptop using USB.

5 Answers 5


enter image description here

Try toggling one of these in developer settings

  • Seriously guys, this is a valid answer.. This is what I do to get it back working. For example, if MTP shows up as 'Unrecognized' in PC, just toggle to PTP for example, and then after PTP drivers are installed, switch back to MTP. It worked for me most of the time. Though I don't know what kind of sorcery is this ;)
    – Gokul NC
    Jul 7, 2016 at 5:37
  • Thank you. This is exactly what I had to do. I had changed it to file transfer mode, but after reconnecting to my PC, it still wouldn't come up. I didn't realize it had automatically went back to charge-only mode. This fixed it :).
    – RastaJedi
    Dec 30, 2020 at 16:39

This is definitely being caused by the drivers. You have to uninstall everything related to your phone from your computer. The drivers, and anything else it installed. Remove all of that, then re-download the drivers for your phone off of google. Install these drivers, then plug the phone in. It should download anything missing now and hopefully recognize the device.

You could even try reinstalling the USB device's drivers itself. On my phone, I can specify whether to host the android device as media storage, image, or charge-only. Try switching between these (if your device allows) and see if that makes a difference.

EDIT: Using DriveDroid, creating an image and hosting that image as a USB flash device would be an appropriate workaround.


Try to clean your USB port. If it is dirty, connection to the PC may fail. I have the same problem, that my S4 Mini is not recognized by the Windows nor Linux. I cleaned the port and at least once I had a connection to heimdall and could run the heimdall print-pit command successfully.

Maybe your USB port is broken then you need to replace it. I haven't done that.



The issue is due to the driver . Install Mobogenie on your system as well as on your mobile . Then connect your mobile n let mobogenie download the drivers . That's it


This issue may be caused by SD card corruption, so please try this solution:

Open cmd as administrator and run chkdsk \f F:/, while F is the path of your SD card , and you need to try it using an SD card ready.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .