1

I'm new to android development so apologies if this is a stupid question.

I'm having trouble seeing my android devices in Eclipse. I've switched on USB debugging, configured them to connect as a camera not mass storage, but when I run ./adb devices, there's no device showing, even though I have a Samsung Galaxy and a LG Nexus connected via USB. On both phones I get a notification saying "USB debugging connected" and "connected as a camera" so the phone obviously thinks it's connected.

The problem appears to be intermittent. Sometimes the Galaxy shows up:

Macbook:~/workspace/android-sdks/platform-tools ./adb devices
List of devices attached 
3334AB246B5300EC    device   

Then I unplug and reconnect it, and it disappears.

I've tried 3 cables and 2 devices now. Should I just give up and use an emulator instead?

0

I know it's too late. but I just had the same problem. I tried to connect my android phone LG Google Nexus 4 with my Macbook pro.

In USB computer connection only "Camera (PTP)" was working but Connect as Media device (MTP) to copy files from Android phone's memory nothing was visible in the mac.

And I got it solved from the following URL http://www.android.com/filetransfer/ provided by the android.com

  • The Android File Transfer tool is for seeing devices in MTP mode. It won't make any difference to adb and USB debugging. – Dan Hulme Jul 14 '14 at 8:26
  • You are right. But I actually needed to copy data from my mobile. otherwise it was working fine with my sdk – MFarooqi Jul 14 '14 at 10:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.