0

When I connect my device to my Linux laptop (debian-Ubuntu) I don't get any output in

adb logcat

If I connect it to another laptop it works fine

in KDE I can open the Directory and copy files, so USB is working

it seems like

adb devices

finds the device:

List of devices attached 
042some_numbers00   device

but it stays disconnected somehow

  • Have you setup ADB accordingly on that KDE machine? – Izzy Feb 17 '14 at 15:29
  • thats the question: what is "accordingly"? – rubo77 Feb 17 '14 at 15:49
  • See e.g. here. – Izzy Feb 17 '14 at 15:58
  • I tried, but still. – rubo77 Feb 17 '14 at 17:06
0

I created a file

sudo nano /etc/udev/rules.d/99-android-mtpfs.rules 

and added

# Nexus 5 (alias Nexus 4) "sudo lsusb" shows: 18d1:4ee2
SUBSYSTEMS=="usb", ATTRS{idVendor}=="18d1", ATTRS{idProduct}=="4ee2", MODE="0666" GROUP="androiddev", SYMLINK+="android%n"

and I added:

echo 0x18d1 >> ~/.android/adb_usb.ini

then I rebooted Ubuntu and it worked!!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.