1

The option to sync calendars is missing from the list for my 2 Google accounts, following some issues with syncing after which I deleted calendar data and calendar storage data.

I have tried reloading the accounts and all the other options come back - except the Calendar sync!!

Please help..

3
  • have you tried adding a 3rd google account; preferably using mobile data, not wifi? see if that brings back calendar sync.
    – geffchang
    Feb 18, 2014 at 17:36
  • Creating a new account hasn't helped. Also if I go into the standard Android calendar (I use aCalendar usually) and try to add an account, there are no Gmail (and I now have 3) accounts listed...
    – Karillion
    Feb 18, 2014 at 18:10
  • sonofabitch - it worked! How I don;t know, but something has changed and restored the sync. Many thanks
    – Karillion
    Feb 18, 2014 at 18:18

2 Answers 2

0

Try adding a new Google account, preferably via mobile data instead of Wi-Fi. It should restore the calendar sync option.

1
  • sonofabitch - it worked! How I don;t know, but something has changed and restored the sync. Many thanks
    – Karillion
    Feb 21, 2014 at 9:04
1

I am assuming you are on a rooted device.

Use your preferred file explorer to browse to : /system/app

There should be two apk files. One the calendar app (calendar.apk) and the other calendarprovider.apk. The second apk provides proper synchronization between the google account and the actual calendar application which is probably missing or not working.

You should be able to find a replacement apk for your specific device and rom on XDA.

1
  • No the device is not rooted. Thanks for offering advice though - lukily another answer solved the problem!
    – Karillion
    Feb 21, 2014 at 9:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .