I know this problem has been reported before, but man, I am really, really getting tired of it. I have not been able to update any app running from the SD card on my HTC Evo since I got it nearly 6 months ago. I just went through all of my apps and documented which ones are on SD storage and phone storage. I was then able to go through my list of updates and select just those that are on phone storage and then all succeeded (11 apps). I then went through some of the ones on SD storage and they all failed (tried 7, but I probably have 10-15 more).

I have tried many of the "fixes" I've seen online like clearing the cache on the Market app. There is not enough internal space for all my apps. I refuse to accept some of the "fixes" as true fixes like deleting the app and reinstalling it or moving the app to the phone storage, updating, and then moving back. Those are not acceptable fixes in my book. This is a major black eye on the Android OS to me. When people ask me if Android is as good as iOS, this problem is front and center in my mind when I tell them that its good, but I'd rather have an iPhone (but, I'd rather have this than my old Blackberry). I get my phone through work, so rooting is not an option. Has anybody else had any success resolving this issue? I'm using the SD card that came with the phone but has anybody had luck with a different brand?

  • I have, on occasion, had a truculent app that wouldn't update properly. Deleting the app and re-installing worked just fine. (It didn't appear to be related to apps on the SD card, though.) Honestly, uninstalling/reinstalling shouldn't take much more time and effort than just doing the update. – ale Feb 25 '11 at 16:05
  • 1
    You're not trying to update apps on the SD card while you have the phone connected to the USB cable, are you? I could see where that would cause a problem. – ale Feb 25 '11 at 16:05
  • I have tried both plugged and unplugged. When plugged, I always make sure the phone is in "Charge only" mode. I don't think you should be forced to uninstall the app to upgrade. You lose whatever customizations you have set up in the app when you do that. At workaround at best, not a fix. – sukach Feb 25 '11 at 16:13
  • @Al Everett - The problem with uninstalling, it will remove any settings associated with the application as well. @Nik Majdan, if you move the app back to phone storage, will it update then? – Ryan Conrad Feb 25 '11 at 16:48
  • 1
    @Ryan. Yes. I moved my DiskUsage app to Phone storage and it updated then I moved it back. Again, merely a workaround. I have about 30 apps that need updating and doing this for all of them would be incredibly time intensive. – sukach Feb 25 '11 at 18:38

How many internal space do you have (check on Settings > SD card & phone storage settings > Internal phone storage > Available Space)? Make sure to leave at least 15-20 MB of internal space (probably larger if you have a large number of large apps) so you can safely update apps. If you have little internal memory left, then updates will fail and "Update All" will fail en masse. The solution is to update the apps one by one, or to clear up some space in the internal memory.

I never had problems with updating apps installed in SD card except when my phone's internal memory reaches about 5-10 MB.

  • I currently have 29MB free, but I've had more and it still failed. – sukach Jun 28 '11 at 13:34
  • 2
    This answer sounds reasonable, but does not solve the issue for me. – gary Jun 29 '11 at 2:43

I asked a similar question a few months ago. Unmounting the SD card and updating seemed to resolve the problem in the short term, but I also get the error every so often when attempting to install updates. I'm not sure what actually causes the problem to occur, but in the meantime I am installing apps onto my SD card and when I get an installation/update unsuccessful, I move it to internal storage. Most of my apps reside just fine on my SD card, so it hasn't been a big deal.

I do sympathize with how annoying it is, though. Best of luck finding a more long-term answer.

  • I read your question before I posted mine. I thought it was a bit different since you were performing an initial installation. Since unmounting your SD card fixed it, I guess the app was trying to install on SD card by default. I didn't know apps did this. We've identified a couple workarounds on this issue but I am hoping to get a more permanent solution. I need to find someone running Gingerbread or Honeycomb and see if they have this issue. Is it safe to assume that not everyone has this problem? Are there people with apps on SD card that can update without issue? – sukach Feb 25 '11 at 19:35
  • @Nik I'd also be curious to find out if it is for some reason related to the Evo (though I'm not sure why it would be). – Dave McClelland Feb 25 '11 at 19:40
  • @Nik: I've had the occasional truculent update but nothing like what you're seeing. I have every app possible on the SD card. Then I have an original Motorola Droid, so I don't know if perhaps some of HTC's customizations are at the root of your issues. – ale Feb 25 '11 at 21:15
  • The documentation I started yesterday on my issue: bit.ly/he3pnc. I'm going to log every attempt at upgrading so I have something to show our phone guy here at work. Maybe my specific phone is the problem. – sukach Feb 25 '11 at 22:23
  • @Nik After reading @user3144's answer, I realized it's probably useful to mention I'm running FreshEvo- That may be useful to someone – Dave McClelland Feb 27 '11 at 0:44

I had the same issue for awhile running Bugless Beast ROM on my Droid and I couldn't get rid of it and finally gave up. Then one day I moved to CyanogenMod 6 (wiped, etc) and the problem stopped.

Wish I could give an easy answer, but, for me, it didn't go away until a wiped everything and started over with a new ROM.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.