I bought a Sandisk Ultra microSDXC card with 64GB to use in my Samsung s3 mini. When I put it in the phone doesn't find it (presumably); going to settings -> storage and scrolling down to the bottom it says

Mount SD card
Insert SD card

but it is greyed out, so nothing happens when I tap it. The SD card seems to work perfecly fine as a storage on my Windows 7 computer.

Googling around it seems I might have to format the SD card to fat32 (I tried first reformatting it with exFat, the default, and also NFTS, to no avail). But that is not an option when using right-click -> format... on windows 7.

So I try Fat32Formatter. When I start it it claims the SD card is in NFTS format (even though it's formatted to exFat). Trying to format it to Fat32 I get the error Failed to determine the drive.

I also tried HP USB disk storage format tool, but when I start it all the options are greyed out and I'm not even able to select a device.

Lastly I tried "MiniTool partition wizard", which indicates that the SD card is (Bad Disk) and doesn't let me format or do anything to it. I try using Partition Recovery Wizard on it, but that doesn't change anything.

Any ideas?

Easy solution for anybody with a card-reader in their pc. (Relaid from: forum.xda-developers.com/)

  1. Place the card in your PC's card reader and determine the drive designation (i.e., G:\, H:\, etc.)
  2. Download the fat32format utility in GUI version from here: http://www.ridgecrop.demon.co.uk/guiformat.exe. Click on the picture to retrieve the file.
  3. Launch the guiformat.exe.
  4. Choose the drive that corresponds to your SD card.
  5. Choose the size of the SD Card you are formatting.
  6. Check the Quick Format box.
  7. Press Start.

Source: http://forum.xda-developers.com/showthread.php?t=1773735

  • Thanks, formatting the card to FAT32 using this tool I got it working! +1 from me. – sbi Jan 2 '15 at 11:51

Firstly you are saying there's no option to format the memory card in fat32 on Windows 7. Which version of Windows 7 are you using??? I have windows 7 home premium and ultimate both have the fat32 as default, infact they have four options to format i.e ntfs, fat, fat32(default), and exfat.

And secondly yes you will need to format that memory card in fat32 format for it to work.

  • 2
    The way I understand it (correct me if I'm wrong), windows can't format 64GB SD cards to Fat32, only those with less storage (I tried making two partitions with 32GB each, didn't work either). – jorgen Feb 20 '14 at 16:33
  • yes it can format.did you try this guide forum.xda-developers.com/showthread.php?t=1773735, i tried it, it worked for me. if this doesn't work you can try this out youtube.com/watch?v=Zsbk7SKonE8 – Aasif Rules Feb 20 '14 at 17:13
  • 1
    Thanks! The second method in the first link works for formatting (I already tried the first method as mentioned in OP) but the phone still can't find the card. I guess there is some other issue.. – jorgen Feb 20 '14 at 17:55

The S3 Mini only supports up to 32GB MicroSD cards. Link

And for reference, no, Windows does not support FAT32 formatting above 32GB.

  • I just got my daughter's S3 mini to work with a 64GB card after I followed FearlessCoward's advice and formated it to FAT32. – sbi Jan 2 '15 at 11:50

Thanks for answers!

It turned out to be a hardware issue. I returned the phone and they repaired it, after which other formatting fixes mentioned above worked (I can't remember which one at the moment).

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.