2

Yesterday on my phone (Android 4.3.2, Galaxy 4S) Chrome started opening the stock browser (just called "Internet") when I clicked on links. That's not what I want -- a browser should use itself to open links unless I tell it otherwise -- so I cleared the default settings first for the other browser and then, when I saw the reverse happen, also for Chrome. So currently I have no default browser and each one asks me what application to use -- every single time.

Before this problem arose, links originating from outside of browsers (like email) opened in the default browser but links from within any browser opened in the originating browser just like you'd expect, with no "what do you want to open with?" dialogue required. What do I need to do to get back to that state?

I intentionally use two different browsers to keep different web-site credentials from bumping into each other. I don't want to always use exactly one.

  • Pop to Settings > Applications > Internet and the "Clear Defaults" and see if that helps. – RossC Feb 21 '14 at 10:54
  • @RossC already did that. That's what I meant by "cleared the default settings"; sorry for the confusion. – Monica Cellio Feb 21 '14 at 13:50
  • Ah sorry, I misread that. This is a know issue afaik, I'll try to find more on it. The 4.3 update has a few issues like this, and I've seen it happen NFC and other places. – RossC Feb 21 '14 at 14:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.