1

I've got almost the same question as the one here however the accepted solution is not working for me.

Whenever I type the word dont the google keyboard automatically corrects it to Dont (capitalizes the D). In the word suggestions it shows the correct auto correct don't to the right of the three suggestions above the keyboard. Additionally if i write dont at the start of a sentence the auto correct comes out as Don't which is correct. And finally lets say I type sont accidentally, the word does get auto corrected to don't, again correctly. So why the word dont auto corrects incorrectly I don't know.

As per the example question the accepted answer was to clear the data for the keyboard, which I have done, but it doesn't change this behaviour...This surely can't be default behaviour of the keyboard can it?

p.s. If it matters this is with the UK english keyboard on 4.4.2

  • Can you long press the 'Dont' in the suggestion box (above the top row of keys) and remove it manually? I Dont (ha ha) have Google Keyboard installed (I don't like it) and this works on SwiftKey and others, worth a shot! Weirdly all of them do suggest 'Dont' as a word though! – RossC Feb 21 '14 at 15:10
  • 1
    No unfortunately long pressing the word only brings up a popup area of a load of other suggested words. I'd try another keyboard, but I've always liked the stock one, and now that it has it's own version of swype I don't have any gripes with it, apart from the aforementioned. p.s. like the pun ;) – Novocaine Feb 21 '14 at 15:14
  • 1
    It's a know issue: productforums.google.com/forum/#!topic/mobile/WPC-UjKkeQA the suggestions there probably won't help but I'll keep digging! The generic advice is: Head over to the Google Keyboard settings, and and tap the Personal dictionary option. Add a new word to the dictionary by using the + symbol. You will now get a pop-up window where you can enter your phrase, and a shortcut to expand that phrase. Now, whenever you type that shortcut in any text-input field, it will be automatically expanded to the phrase you wanted. – RossC Feb 21 '14 at 15:17
  • If you go to Settings > Language & input > Settings Icon beside Google Keyboard > Personal Dictionary can you remove Dont from there? – RossC Feb 21 '14 at 15:24
  • 1
    I've only got one word in the personal dictionary, and Dont is not it, and I just tried adding dont to the dictionary which doesn't auto correct to don't however it does stop it correcting to Dont which is a start I gues... – Novocaine Feb 21 '14 at 15:41
5

Check your contacts. Keyboard will search and suggest contact names.

  • Ha, unbelievable. That was actually it. I had a contact saved as Dont Answer from a long time ago, so I removed it and cleared the keyboard data and hey presto it now auto corrects correctly! Shame I use swiftkey now anyway. – Novocaine Jul 15 '14 at 8:15

protected by Community May 12 '15 at 20:32

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.