4

I have an old phone (LG P350) with Android 2.2.2, where I obviously have a few contacts. Most of them are contacts with telephone numbers, which I manually created (few got automatically imported from facebook or email).

Now I have a new LG phone with Android 2.3.6. I want to have on the new phone all the contacts I had on the old one. I mean the contacts that you see when you tap on the Contacts icon.

It should be a complete no-brainer, but apparently it isn't.

Note: I don't use the GMail application neither on the old phone nor the new one, and I don't want to. I do have my @gmail.com account set as the main account for both phones.

On both the old and new phone, under Settings -> Accounts and Sync, the "Auto-sync" option is enabled. Also, under the ...@gmail.com account listed below "manage accounts", I have enabled both "Sync people details" and "Sync contacts", both on the new and old phone.

However, my contacts don't get synced. I have a lot of contacts in the old phone that I can't find in the new one. The new phone apparently has imported all the mess of useless contacts from gmail (i.e. email addresses some with and some without names) but no phone numbers.

So how do I sync, or export and then import ALL my contacts?

  • 1
    I finally managed to copy the contacts by exporting them from the old phone and importing them (Contacts -> Settings button -> Import/Export -> Export to SD card ...) which didn't work the first time because the exported file got somehow corrupted. However I still would like to know why the normal sync doesn't work and what one would have to do in order to get the normal sync to work – matteo Feb 23 '14 at 20:37
  • 1
    The first part of your comment should be an answer, matteo! As for the second part: the "normal sync" only picks contacts stored as "Google contacts". Maybe you had some of them stored "locally" instead. Or on SIM. – Izzy Feb 23 '14 at 20:53
  • Oh, so there is a difference between a "google contact" and a "local contact"? That should be the answer I guess. None of my contacts were on sim. Whenever I created a contact I was never offered a choice whether to store them as "local" or as "google contacts", the only choice was between "phone" or "sim" (and I always saved them on phone). – matteo Feb 24 '14 at 1:15
  • Now that I have imported them to the new phone, I notice they all appear as "google contact"s. On the old phone, however, they all show up as "LG PC Suite contact"s. And there's no option to change that. The whole thing is pretty stupid. "Sync"ing should just mean uploading/downloading all contacts. Anyways... – matteo Feb 24 '14 at 1:22
  • Before we fight what should be the answer, I've summed it all up. And yes, I've missed that option (to move contacts between storages) as well a couple of times. I've got no idea why that's missing (or where it's hiding), unfortunately. – Izzy Feb 24 '14 at 7:12
3

As you've already figured, a built-in solution is:

  • Open the contacts app on the "old device"
  • In Menu → Import/Export, chose to export
  • Copy the resulting 0001.vcf file to your "new device"
  • On the new device, open the contacts app and chose to "import" from Menu → Import/Export

Hint: take care there's enough free space available on the "exporting" device (file might get large, as contact pictures are stored inside it as well). You might not always get a warning when storage runs full, but instead end up with some "incomplete export", which then cannot be imported on the other end.


Now for the second part: why didn't they sync automatically? First, there are a few different "storages" to be considered:

  • On SIM
  • Google Contacts

These two are available on all devices. Depending on device and ROM, there might be additional "storages", e.g.

  • Exchange
  • PC Suite

Assuming you're speaking of Google's sync: That only takes care for Google contacts. As the PC Suite would only cater contacts in PC Suite to sync them with its desktop counterpart, and Exchange would not care for anything but Exchange contacts (you wouldn't want your personal contacts appearing in your company's address books, would you?). SIM contacts are a very special case: Nothing cares to sync them anywhere. I'm not even sure whether Import/Export is touching them.

So as parts of your contacts have been stored as "LG PC Suite contacts", these have not been sync'd with Google (and your "Google contacts" not with LG Suite), which explains the miss.

  • Thanks. Actually when I posted the question I had already tried the export/import thing and it failed, which is why I asked, since there seemed to be no way. But then I realized the file had simply got corrupted when exporting "because" there wasn't enough space to save it (a shame that the system decided to save "half" of it without giving an error message). As an aside, If anybody from Google read this, I hope they notice how stupid it is to not give an option to sync also "non-google" contacts, OR at least an option to move contacts from other "storages" to "google contacts". – matteo Feb 24 '14 at 22:13
  • While I agree to the latter (move-option), I'm glad the former does not exist. People may have specific reasons they prefer to have some data not synced with Google. // Thanks for the storage-full hint, btw. Integrated that with my answer. – Izzy Feb 24 '14 at 22:17
  • While I agree with that method, you'll find stucked in unpleasant situations. The method works in general, but it fails when (e.g.) a more than 1 note has been assigned to a contact: only the first one will be copied. – sataniccrow Dec 27 '14 at 11:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.