3

A relative of mine brought me his Galaxy S4 Mini GT-I9190, which is stuck at boot. When I boot into recovery it gives the error Failed to mount /system (invalid argument).

How can I dig through the file-system of an android phone which doesn't boot, except in Recovery? The goal is not to flash it but to recover the data if possible.

I don't mind rooting or flashing, but I don't want to overwrite the system partition that may still have the valuable info on it. I've managed to install clockworkmod according to these instructions.

Is there a way to mount it, or expose the raw device to USB, or just back it up to SD, without overwriting it?

EDIT: Now I have Clockworkmod installed. Trying to use it to make a backup of /system. It fails to mount /system with the message:

mounting /dev/block/platform/msm_sdcc.1/b/system on /system failed: Invalid Argument
W:failed to mount /dev/block/platform/msm_sdcc.1/by-name/system (File exists)

EDIT 2: with ADB shell I looked into /system, found an empty folder called bin and removed it. Now mounting /system fails with a longer error:

Error mounting /system!
W:failed to mount /dev/block/platform/msm_sdcc.1/by-name/system (File exists)
I:Can't partition non mmcblk device: /devices/platform/msm_sdcc.3/mmc_host
  • Mind me asking, how did this happen? Why are you booting into recovery anyway? – t0mm13b Feb 23 '14 at 21:51
  • It's stuck, won't boot any other way. – tomnexus Feb 23 '14 at 21:54
  • Right, how did it get stuck? :) Were you attempting to install CWM or attempting to root? – t0mm13b Feb 23 '14 at 21:54
  • @tomnexus I've just integrated the information of your last 2 comments into your question (please remember you can and should always edit it to make important information part of where it's seen ;) So you might consider deleting those comments for a clean-up. // as for the error: I'm not 100% sure, but it looks like the directory /system is not empty, and that's why mount fails. When in recovery, can you try to verify that – e.g. using adb shell to ls /system? – Izzy Feb 23 '14 at 22:13
  • figured out ADB and logged in. ls /system showed one empty folder called bin inside. I removed it with rmdir bin. Same error trying to mount the folder. New error in the logs (above) – tomnexus Feb 23 '14 at 23:00
1

My not-so-great solution ended up like this:

  1. ClockWorkMod, installed with Odin according to the instructions (Odin seems to be slightly un-official so you're unfortunately always downloading from someone's Box or google drive, which is a bit uncomfortable)
  2. ADB shell, (on PC: install java SDK, install android development kit)
    1. Mount the SD card with CWM
    2. In the shell, using DD to clone the unmountable partitions I wanted onto the SD, for later recovery
    3. using CWM to mount the SD as a USB drive, moving the piece-of-partition to the PC
    4. Repeat
  3. Download fresh firmware from Sammobile and flash with Odin
  4. Scratch through the partitions with a hex editor, to find the data I needed. Fortunately this was just text, things like pictures would have been harder.

A few features were still not working, WiFi for one, so the phone had to go back to the shop to be flashed with official firmware. At least it had the official bootloader on it at that stage, not CWM.

  • I'm in the same situation, but i didn't make it pass step 1 :), probably because i didn't have USB Debug active at the moment of failure? – user311174 Dec 28 '14 at 23:48
  • This wasn't in any debug mode, it just stopped working. Some sort of very rare memory corruption I guess. It probably depends on what exactly went wrong, whether you can even enter recovery mode or not. In my case the fault was only in the main partition. Sorry :-/ – tomnexus Dec 28 '14 at 23:57
1

I just ran into this issue and my fix was flashing TWRP and using their partition file system correction tools. I used rashr to replace CWM recovery with TWRP and after the fixes from TWRP, I was able to flash ROMs again.

0
  1. Just enter into fast boot mode and connect my mobile with PC

  2. Just flash the same ROM, Which I have already have in my mobile (I haven't done "erase userdata")

  3. After flashing the ROM, Reboot my mobile

  4. I got all apps and datas.

  5. Also, I connected my mobile with PC, now its detected the internal memory of my mobile, here I can copy the required pictures and data to my PC.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.