Yesterday I upgraded my Samsung Galaxy S4 to Android 4.4 KitKat and had the bad surprise that it cannot write to my SD card anymore... I know this problem is widely documented everywhere, but has any workaround been found for it yet? (Other than removing the card physically from the phone and opening it on my PC) Also, because of the KNOX flag I can't downgrade to 4.3...

(PS: Rooted or not, it makes no difference)

  • 2
    @t0mm13b ah, that's not ideal. I knew that change was there alright, but I was under the (obviously wrong) impression that Samsung would patch this to work on their own device with official ROM as they still 'support' EXT-SD cards. On a rooted device SOME have had success with folder mount, but others have bricked their device. Try XDA and see what's there, it is being worked on but I've not see a definitive answer.
    – RossC
    Feb 26, 2014 at 11:57
  • 1
    In short, the real workaround, is to change one line in the manifest within the kitkat source and recompile the rom and flash it. Google are clear on moving away from SDCards, flash memory capacity are increasing, and cheap to embed on device board, and furthermore, using cloud services for storage. Its a major inconvenience, perhaps someone with Xposed framework might circumvent it.... pita..
    – t0mm13b
    Feb 26, 2014 at 12:36
  • 1
    @DanHulme complaining to author of app is not the solution. Its a drastic change by Google...
    – t0mm13b
    Feb 26, 2014 at 12:43
  • 1
    The permission's existed since API 16, and there's been a big warning in the official training for as long as I can remember.
    – Dan Hulme
    Feb 26, 2014 at 12:58
  • 1
    It's still a dumbass move. Why should we be forced to store all our downloads on internal memory? The whole point (more or less) of having an SD slot is so we can dump a bunch of media onto a card and swap one collection for another. I suppose Google wants us all to use "cloud memory" which is worthless when off the network. Feb 26, 2014 at 15:39

3 Answers 3


Found an answer to my own question! Might as well share how I did it (DO IT AT YOUR OWN RISK, it worked fine for me). Needs root obviously.

  1. Using a root-enabled file manager, navigate to /system/etc/permissions
  2. Edit platform.xml and find the WRITE_EXTERNAL_STORAGE permission.
  3. Add an additional group definition for this permission...<group gid="media_rw" />
  4. Save the changes to the file.
  5. Restart.

Credits go to mateenf from the XDA-developers forum


I used this workaround to edit tags from my external SD card on my rooted LG G3 (LG-D851). Audio player is PowerAmp.

  1. Download and install Xposed installer from the Google Playstore: Instructions: https://www.youtube.com/watch?v=nj_fgrpgDRU (GadgetHacks)
  2. In Xposed Installer click on "Download." (you may have to hit refresh symbol to load modules).
  3. Click on and download "KitKat SD Card Full Access" from the repository. Make sure you have the download from Unknown Sources box checked (settings >security >unknown sources).
  4. Once the module has been downloaded and installed, reboot your phone and tag away to your heart's content.
  • 1
    No need for an Xposed module, there are plenty of apps in the Play store now to do that (they all require root, obviously). Look for "SD Fix" in the Play store, you'll find them.
    – Guillaume
    Nov 27, 2014 at 10:45
  • Now you tell me...lol. Good looking out!
    – Heru Ammen
    Nov 28, 2014 at 7:03
  • 1
    These apps didn't exist at the time I asked the question :)
    – Guillaume
    Dec 1, 2014 at 13:59

I found a way better solution! With uTorrent I was not able to write to


But I am able to write to:


So look for a folder on the SD card that your app has access to given by Android.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .