13

This is a Nexus device running the latest stock OS version (v4.4.2), I already have Google Play Services installed (v4.2.43 according to the App Info in settings). Why is some unknown app asking me to update it? (I realise that the com.google.android part of the package name indicates that this probably an app made by Google that is probably part of their Google layer on top of AOSP Android, but why the odd error message and lack of proper app name)?

An application requires installation of Google Play Services: Requested by com.google.android.gsf.login

An application requires installation of Google Play Services
Requested by com.google.android.gsf.login

What is com.google.android.gsf.login and why should I do what it is asking? It doesn't have a store page and it doesn't appear in my apps list with that name. A bit of investigation with Android System Info's more detailed Apps view shows that Google Services Framework is com.google.android.gsf and the Google Account Manager is the com.google.android.gsf.login that we're looking for.

com.google.android.gsf in ASI com.google.android.gsf.login in ASI

Clicking the notification from Android's notification bar takes me to the Play Store's page for Google Play Services where the latest version mentioned in the "What's New" section is 4.2.42, which is older than what I've already got installed, and I don't have an Update button (which suggests I'm already running the latest version).

2

I have had a similar issue on my Nexus 4 device, here is what I did to stop the issue:

Go to your 'Settings' menu, then go to 'Accounts'. Select 'Google' and check which google service has a sync issue. If you cant see any apps with sync issues, you will have to do as user 'Laural H' mentioned above: disable them all, and re-enable them one by one, checking that it syncs properly (before enabling the next one). When you find the app with sync issues, open the problematic app and login with your google credentials.

1

You could try installing the newest version of Google Play . If you don't want to do that, try one of these:

  1. Go to Settings->Accounts->Google->Sync Data and disable all your Google Account sync items individually. Then enable the App Data and try again before enabling the rest of your sync items.

  2. Go to Settings->Apps->Menu->clear app preferences.

  3. Clearing the Play cache.
  • 1
    Link is now broken. – mizipzor Jun 25 '16 at 9:54

protected by Community Dec 7 '14 at 22:16

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.