1

Preface - I originally posted this on stack exchange, which is where I found the question in my first link, but I was directed to post here instead.


NOTE: I have already looked at the following link but none of the answers solved my issue. https://stackoverflow.com/questions/16818049/insufficient-storage-available-even-there-is-lot-of-free-space-in-device-memor

I should add that I recently freed up a bunch of space on my phone as I described here: http://forums.androidcentral.com/verizon-galaxy-s-iii/262892-storage-space-running-out-3.html#post3477534

So my issue is that I recently was low on space and found how to clear a lot of files I no longer needed, which gave me a lot of space. But fast forward to now, Twitter and Candy Crush want to update, but they tell me that I have insufficient space. But, I have ~6.5GB free on my internal memory, so that can't be the issue.

Because I am on a Galaxy S3, I am unable to move apps to my external card (which is dumb, but whatever), but I don't see how that could be an issue, since it is reporting so much free space on the internal memory.

I am on a custom ROM (Carbon) which is CM-based, so trying the special codes in my dialer don't work, and I can't find a /data/log directory, as I saw suggested in another answer (the data directory exists, but there is no log folder). I have tried uninstalling Twitter and reinstalling it, but now it won't let it install either, so I'm stuck for now without twitter on my phone unless I use my browser (not that I use twitter much, so no big loss). I have also tried clearing my cache and dalvik cache via CWM recovery, and that didn't fix the issue either.

I'm wondering if the device for some reason still thinks it has less than a GB of space, as it did before I did as described in the second link above, even though it shows 6.5GB free in Settings -> Storage.

Note that I am able to install some apps (I installed the terminal emulator, for instance, but that's tiny), but specifically Twitter didn't want to install or update, and Candy Crush won't update (I haven't tried reinstalling it because I don't want to lose that game).

Is anyone else experiencing a similar issue, or better yet, has anyone fixed a similar issue?

2

I was having this problem on my Verizon Galaxy S4 (i545). I could not figure it out for two or three days straight. Finally, I looked into my /data folder and saw a folder located at /data/app-lib which contained some data from Candy Crush. The folder was the same as the apk title: com.king.candycrushsaga-1 After deleting this folder (you may want to back it up first), I was able to install Candy Crush again with no problem. Hope this helps!

  • Thanks, that did the trick, both for candy crush and twitter. Even though I had uninstalled the twitter app, the files were still there in the /data/app-lib folder. I deleted the ones associated with those apps and redownloaded the apps, and everything works great. Thanks again! – imkingdavid Feb 28 '14 at 6:06
  • Glad I could help! – Tyler W. Feb 28 '14 at 14:44

protected by Community Oct 20 '14 at 12:54

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.