1

I have a aroblem with my rooted Galaxy Nexus running Paranoid Android 4.3 (3.99). I have 2 folders in the main memory named /rom and /roms which I cannot remove nor with a file manager nor with a terminal. Can anybody help me?

Here is my console output:

root@maguro:/ # cd storage/sdcard0/     

root@maguro:/storage/sdcard0 # ls -al
[[many more, I am hiding the rest]]
drwxrwxr-x root     sdcard_rw          2014-01-14 20:02 rom
drwxrwxr-x root     sdcard_rw          2013-10-12 11:45 roms

root@maguro:/storage/sdcard0 # rm -rf rom
rm failed for rom, Permission denied

255|root@maguro:/storage/sdcard0 # rm -rf roms
rm failed for roms, Permission denied

255|root@maguro:/storage/sdcard0 # 
  • I know you're running as root but....have you tried this command WITH sudo? – mjrider Mar 9 '14 at 17:45
  • your syntax looks correct according to the man page can you try rm -Rv ./rom -v turns switches into verbose -v, --verbose Explain what is being done – mjrider Mar 9 '14 at 17:53
  • Okay I found another solution: I went into TWRP and deleted them with the file manager. – flameNugget Mar 10 '14 at 13:07
  • Might be already too long already, but could you post your comment as an answer, if that really solved your issue? Self-answering is acceptable and even encouraged here. – Andrew T. Mar 31 '15 at 9:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.