3

I tried to get CM11 on my LG G2 on Bell Canada's network and I really messed it up. I can no longer get into recovery, adb doesn't see my phone, but download mode works (though I have no idea how to use it). I even tried the "Get out of Fastboot" tutorial and it didn't work because when I get to the point where I have to choose "Android" under "other devices" in Windows 7 and my G2 is showing up as "SAMSUNG Android Phone" and under that it says "USB Modem Phone ADB Port". The latest drivers for LG are installed so I have no idea what's going on. I had a Samsung Galaxy S2 a long time ago. Could it be that those drivers are over-riding LG's drivers? I have no idea how this stuff works...

So now my phone boot loops to little rows of words at the top of the screen: [650] Fastboot mode started [700] udc_start()

Please, what can I do to fix this phone? I need a simple tutorial for a total noob like myself.

Thanks!

Secondly, is there any way I can get CM11 on this Bell phone? I don't like LG's skin...

  • I would start by un-installing all Samsung drivers, including their Kies application. Then un-install and re-install LG drivers and see if this resolves your machine not recognizing the phone in fastboot mode. Also, ADB will not recognize the phone while it's in fastboot mode. You will need to use the fastboot.exe tool (found in the same place where adb.exe is installed.) – Chahk Mar 11 '14 at 15:03
  • There is most definitely a CM11 version for LG G2. Depending on your exact model number (d800 for AT&T, d801 for T-Mobile, and d802 for International) you can find it on download.cyanogenmod.org – Chahk Mar 11 '14 at 15:07
  • Chahk, Thanks for the quick responses! Those CM11's you're talking about aren't for the D803 (the Canadian version). I tried a D802 CM11 on my D803 and that's what got me into this mess. Any way to get a D803 version? Or will I just have to wait and hope? – Brian Mar 11 '14 at 15:25
  • Chahk, I just removed the Samsung driver and all the other crap, rebooted and reinstalled the latest LG driver. The PC is still seeing my G2 as "Samsung Android Phone" and under that "USB Modem Phone ADB Port". Also, when I open CMD and type "Fastboot devices" it says "? fastboot" I'm guessing that means it knows there's a device but doesn't know what it is... Damn this is frustrating. I hope I haven't completely bricked my phone... – Brian Mar 11 '14 at 15:30
  • Alright so I may be making some progress here... I'm going to write this out as I learn it. I opened cmd typed "fastboot" then typed "cd \tools" (this tells fastboot to look in my C: drive at a folder called "tools". There was no folder called "tools" in my C: drive so I made one. On the next line I typed "fastboot flash recovery boot.img" the part that says "boot.img" is just the name of the .img file you're trying to flash. I tried to flash a .zip before and it said... – Brian Mar 11 '14 at 17:13
1

If your computer is able to recognize the phone while it's in Fastboot mode, you are half-way there. You will now need to flash a proper Recovery image, and then use the Recovery mode to flash a compatible ROM.

It doesn't looks like ClockworkMod officially supports your version of LG G2 (d803). The other well known recovery is TWRP (short for Team Win Recovery Project). There are two different recovery images for d803 - Bell and Rogers. Go ahead and download the one appropriate for your carrier, and save it somewhere on your computer.

Now do the following:

  1. Boot up your phone into fastboot mode, and connect it via USB to the PC.
  2. Open Windows Command Prompt, and navigate to wherever the fastboot.exe program is installed (e.g. cd c:\fastboot\)
  3. Issue the following command: fastboot flash recovery [path-to-img] where "[path-to-img]" is the full path to where you downloaded the recovery image (C:\temp\openrecovery-twrp-2.6.3.2-g2bell.img for example)

Turn the phone off, diaconnect it from USB, and boot to recovery by holding the Vol Down+Power buttons, then as soon as the "LG" logo comes up release them and press & hold them again, and then on the screen press the Power button 3 times.

You should be in TWRP recovery. Re-connect the phone to PC via USB, and now ADB tool should be working.

You can now try to find the CM11 version for your phone, adb push it to your phone's memory while it's in Recovery mode, and then flash it with TWRP. I would also recommend performing a complete wipe via TWRP to clear out any residual files from your previous flashing attempts.

Currently CyanogenMod does not officially support the Canadian variant (d803) of LG G2, but some people had successfully modified the d802's package. This involves extracting a file from the official CM11 zip, modifying it to include the d803 model, re-packing it into the zip, and finally flashing it. A different kernel is also required to be flashed right afterwards, and can be found here (you will need the AOSP based one.)

| improve this answer | |
  • Chahk! You're the best! If you were here I'd have to buy you a beer or something. I can't describe how much suffering you've saved me from! I thought I'd have to buy a new phone! – Brian Mar 11 '14 at 20:12
  • Now, I just have to see if I can figure out the cm11 thing. I don't want to go back to lg... – Brian Mar 11 '14 at 20:12
  • Alright... Chahk? I'm in TWRP now but I cannot push the roms. When I type "adb push Cyanogen11-D803.zip" it just give me the adb menu again and nothing happens. If I type "adb sideload Cyanogen11-D803.zip" it starts doing it's thing it gets to 100% then twrp on my phone says "failed" at the top in red letters. What am I doing wrong? I even tried it with the official bell.zip and it doesn't work either... – Brian Mar 12 '14 at 0:05
  • Alright so I figured it out. I needed to reboot to system through TWRP then it took me back to fastboot. I then had to reflash the recovery with fastboot and then TWRP finally sideloaded the rom correctly using the command "adb sideload ROM.zip" so it worked! – Brian Mar 12 '14 at 3:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.