I'm trying to do an adb backup of my Galaxy S3 (i747m), but after receiving the "Now unlock your device and confirm the backup operation" order from adb, I never receive the prompt on the device. It just sits there.

Locking and unlocking it does nothing, entering the command locked or unlocked changes nothing, setting the desktop backup password in development options does nothing, disabling the lockscreen does nothing.

Device is running the stock Samsung 4.1 ROM and is rooted. Computer is windows 7.

How can I get this backup to go through?

  • (1) Did you enable USB debugging? (2) What command are you using? adb backup -apk -shared -all -f mybackup.ab?
    – geffchang
    Commented Mar 13, 2014 at 8:05
  • @geffchang - 1. Yes. 2. adb backup -apk -noshared -nosystem -f pre-cyan.ab the .ab file gets creayed, but it remains empty.
    – Compro01
    Commented Mar 13, 2014 at 13:02

1 Answer 1


I'm digging up this question since I found it looking for the same problem.

Putting single quotes around the parameters solved it for me:

adb backup '-all -apk -shared -f mymobile.ab'
  • I had the same problem as OP with a Huawei KIW-L21, and your answer solved it, thanks.
    – G Cab
    Commented Aug 30, 2017 at 14:30
  • Noice ! Solved for me
    – btc4cash
    Commented Apr 17, 2020 at 5:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .