1

I have a Samsung Galaxy S2 (SPH-D710) and was trying to do a firmware upgrade through Kies and the upgrade encountered an error (I think the usb cable came loose and lost connection). After that, when I tried booting the phone a screen appears with a yellow triangle with an exclamation point in the middle, a phone to the left of it and computer to the right with the message "Firmware upgrade encountered an issue. Please select recovery mode in Kies & try again". I tried doing the emergency firmware recovery in Kies but that seemed to freeze at 64%. I wasn't sure how long it was supposed to take so I let it sit there. Eventually the battery level went low enough that the recovery failed and now the battery is too low to boot into download/recovery mode. When I plug the phone in to try to charge the battery the "Firmware upgrade encountered an issue. Please select recovery mode in Kies & try again" screen flashes and it doesn't seem like the battery is charging. Is my phone completely screwed? Is there anything I can do at home to fix this or will I have to take it somewhere?

Thanks

1

Yes, turn off the phone and try to charge from a wall charger, and when battery is full, try to do firmware recovery, this time use a good usb cable, and ensure a good Internet connection.

Keep battery level above 80% or keep it full.

And if all fails go to service center.

Vote up if I helped ;)

  • I've tried plugging in to a wall charger after turning the phone off, but it just flashes the firmware upgrade issue screen and doesn't seem to charge the phone. So I'm currently stuck in the position that the phone won't charge and I can't get into download/recovery mode. – Nick Mar 16 '14 at 17:08
  • If u have someone with same device, try charging your battery some way and follow the recovery steps. :) – coolhz Mar 17 '14 at 14:46
1

I ended up borrowing a battery to finish the emergency firmware recovery in Kies. The second attempt proved successful in the firmware upgrade, however, still had network connection problems. I took it into a Sprint service center and they tried doing software updates to the phone. Tech had to do the software updates several times. Found that after each update attempt, phone would work, but connectivity issues would come back after inserting the SD card. He deemed the SD card to be corrupt. Phone is now working fine on the latest firmware with a new SD card installed. I am not sure what exactly is on the old SD card that would have corrupt it.

Thanks for the suggestions.

1

If you still have the original usb cable then use it because it probably is modified by Samsung.

Consider upgrading to latest Android (currently 4.4.2) it is well worth it you wont brick it, I did it with my first Smartphone 3 years ago (I still use it) just when I got it and I've done all I wanted to do like install root Rom kernel audio engine etc removed bloatware and lots more :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.