0

I'm sorry to bother you but I couldn't find anything anywhere on this:

I installed CM a couple of days ago on my Samsung i9305 (Galaxy S3 LTE - CM stable release 10.1.3 based on Android 4.2.2) and so far am very happy about it. There is one thing to annoy me though and I couldn't find a way to change it.

I'm using my phone a lot to write, especially when it's dark, so naturally I've chosen dark themed text editors. On portrait, text input is as it should, I can write simply within the dark themed app. As soon as I put the phone in portrait mode (which is desired for longer texts), I get this awful white text input thing popping up with the "done"-button on its side which really takes me out of it (Form editor?). I have searched the settings high and low, tried changing the theme and have tried installing other keyboards (which has nothing to do with it but it was worth a shot) but no success.

Is there any way to get rid of that function? It may be possible for it to just be an Android 4.2.2 feature, which I would find odd since it breaks the immersion into an app, so the question remains.

Thank you very much for your effort.

1

enter image description here

I assume you have a screen like this one? There's a way to disable the so called "fullscreen landscape keyboard". Some custom roms have feature an option by default, but not CyanogenMod.

What you could try is to download the Xposed Framework and disable that fullscreen landscape keyboard through Xposed Modules like "Gravity Box" or "XBlast Tools".

Those two modules also feature a lot of other useful tweaks.

I hope I understood you correctly and that this will be helpful.

EDIT: Those two modules I mentioned above may be a bit confusing at first. So I would rather recommend this module instead: No Fullscreen Keyboard Xposed - Android Apps on Google Play

  • That's an idea, thanks! I've actually used XPosed on my phone before installing Cyanogenmod but have never needed these mpdules specifically. I'll try right now. – Halest Mar 18 '14 at 12:59
  • This answer is correct, though "No Full Screen Keyboard" didn't do the job. XBlast did it! Thank you very much. – Halest Mar 18 '14 at 13:33
  • You're most welcome! – VollNoob Mar 18 '14 at 18:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.