I have a Galaxy S plus (GT I9001), I installed Tiger Jelly Bean recently, which was working fine. But phone was lagging a lot so I decided to install the stock rom again. I installed Kies(latest version) with drivers and connected my phone to my PC, but it was not detected by Odin. Every time I got Samsung Composite USB Device driver installation failed. So I searched and installed drivers from Here and Here . But they didn't worked either. I tried again after changing USB Cable but still no luck. Then I installed Kies in my Laptop and tried to connect the phone. Still it wasn't recognized.

Things were not working with downloading mode and Stock rom tar file cannot be flashed with recovery mode. So I searched a converter for .tar to flash able .zip file and found THIS. I installed this tool and tried to convert the tar file to zip. Didn't noticed that it require knowing "Mount Point", so I converted the tar file to zip without changing the mount point and copied the file to internal storage of phone and flashed the zip file. After that phone restarted , and stuck at Samsung Logo.

New I can't even to recovery Mode, nothing happens when I keep Pressing Vol Up + Power. Phone starts and stuck at samsung logo. Odin was already not detecting the phone so I tried connecting the phone on Ramdump Mode and some how drivers were installed and odin detected it correctly. But odin can't flash phone in ramdump mode so it didn't worked.

So now the problems I am facing are: 1- Phone is stuck at samsung logo, can't go in recovery mode. 2- Odin not detecting phone in downloading mode.

Is there something what I can do to fix this? Please help!

Thank you.

  • Did you uninstall Kies before trying the drivers from the first link you posted? Mar 20, 2014 at 11:26
  • Yes I did, I uninstalled Kies and then installed the driver.
    – ygssoni
    Mar 20, 2014 at 11:49
  • @ygssoni, could you remove all the drivers for your phone. You can use this link for reference. Then restart the PC and try reconnecting the device. It might detect, if not re-install the drivers from your link. It might work.
    – k1chy
    Mar 21, 2014 at 3:21
  • @ygssoni uninstall the kies or be sure there is no process of kies is running then use ODIn otherwise ODIN will not work. Also press the VolDown+Home+Power button to start the phone in download mode.
    – avirk
    Mar 22, 2014 at 15:34

2 Answers 2


I also faced the same problem in my phone, when I flashed a wrong Rom. But I had USB Jig which reset my phone to Download mode automatically. Then I was able to flash with ODIN.

Try using USB Jig (you can buy it on eBay) to force your phone into Download mode.

  • I can go into download mode, but the problem is sometime the phone is detected ,some times not.And when it is detected the odin always stuck at check plcatform verification
    – ygssoni
    Mar 21, 2014 at 5:44

There are different boot combos for different galaxies.

On my phone it is up + home + power. Sometimes I have to hold it for almost two minutes for some reason.

If you cant boot injto recovery then boot into bootloader/downloadmode and flash there with .exe like odin or heimdall.On my phone down home power boots into bootloader.

Make sure the drivers are newest from samsung official site

  • I can go into download mode, but the problem is sometime the phone is detected ,some times not.And when it is detected the odin always stuck at check plcatform verification
    – ygssoni
    Mar 21, 2014 at 5:43
  • When I first rooted my galaxy It had detection problems and when it would magically somehow detect my phone the flashing wouldn't finish; often because of an error.I fixed it by using the latest available version which was 3.09 at the time (not some outdated 1.85) and using latest drivers from official samsung site. IF you don't have root the file you are flashing via odin or recovery or anything else needs to be signed otherwise it will be rejected SO you flash a signed file that will enable you to flash unsigned files like roms kernels audio engines anything you want
    – user42276
    Mar 21, 2014 at 13:48
  • If above doesn't work try the same but with Heimdall instead of ODIN
    – user42276
    Mar 21, 2014 at 13:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .