I tried rebooting my phone, reset to default on APN , safe mode but nothing seems to work.I still dont get internet on my phone.I'm from India and connection is docomo.

Any help would be greatly appreciated.

1 Answer 1


Go to

Settings > More > Mobile Networks > "Use only 2G Networks"

Make sure the above option is unchecked and you've correctly activated a proper 3G plan. Also, don't forget to configure the APN for using the internet.

  • Im using 3g for the past three months since i bought the phone.And its in LTE mode.
    – Joseph
    Mar 19, 2014 at 11:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .