0

After rooting my Sony Xperia P, the GPS stopped working. Even Google Maps can't find my current location now. I found this problem when started working on Location API.

Is it a common issue and is it resolvable? I tried searching on XDA too, but couldn't find anything about this.

  • What root apps have you installed, or what other root changes have you made? – Dan Hulme Mar 19 '14 at 21:03
  • I have used this guide to root my phone - xperiahtcrootingrom.com/root-sony-xperia-p-ics-jellybean – noob Mar 20 '14 at 5:39
  • Right, and after you rooted it, what did you use root for? – Dan Hulme Mar 20 '14 at 9:14
  • ohk, it happened just after rooting it. I've although installed just ES file Explorer with root permission. I do not use this device often so didn't even install any other app after root. – noob Mar 20 '14 at 9:38
0

Ok the GPS started working again. I let the phone drain out of battery, then put a charger and let the sony logo show till the charge gets around 80% (Just left it for 20-30 minutes on charge). Then I removed the charger and hard reset the device(hold power and volume up key for few seconds). The device will shutdown and then restart it normally. Google will ask if you'd want to permit google to collect anonymous location data. Press allow and check GPS by opening Google maps app, it's working :-)

PS: Dunno what worked here(probably the hard reset step), but I put all the steps just in case.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.