I have a rooted Samsung s3 mini, android version 4.1.2

How to show the saved wifi password of the router I am connected to?


2 Answers 2


From any file manager that allows root access to system files you can go into /data/misc/wifi/wpa_supplicant.conf file or directly search for wpa_supplicant.conf file.

You can open it with any text editor.

If you have Terminal Emulator you can also do this:

cat /data/misc/wifi/wpa_supplicant.conf

You will find all your saved passwords inside that file. Password will be stored as:

  • One more thing do I need to root my device in order to do that or it do works with unrooted device too ? as I can't find anything inside /data folder. Commented Nov 10, 2014 at 6:36
  • You would get permission denied of you would need root access and not have it. I can't answer your question direcy, but it might be that you are using different version of android which keeps the file in a different place. If you provide more details on your device and OS I might help you.
    – user55027
    Commented Nov 11, 2014 at 13:18
  • I am currently running Samsung Stock 4.1.2 Jellybean ROM over tab2. I have tried looking over the /data folder but the specified misc/wifi/wpa_supplicant.conf file isn't there ! Commented Nov 12, 2014 at 3:29
  • 1
    are the directories there? You can try to run this command to find it: find /data -name "wpa_supplicant.conf" or even find / -name "wpa_supplicant.conf" Anyway, I am pretty sure now that you need a rooted device.
    – user55027
    Commented Nov 12, 2014 at 22:01
  • Well, @edvinas.me I have tried searching for -name"wpa_supplicant.conf" under data file but can't find it in the data folder instead of it has something else like log.txt and com.onelou....oneweather . I guess device needs to be rooted any way thanks though ! Commented Nov 13, 2014 at 4:01

You can also download the app "Wifi Key Recovery" which is a lot easier.

  • The thing is I don't like giving root access to apps unless I really need them, but thank you for trying to help :)
    – Lynob
    Commented Mar 27, 2014 at 18:56
  • Worked perfectly! For some reason the text file wasn't in the path the other user suggested
    – Pitto
    Commented Dec 22, 2014 at 14:28

Not the answer you're looking for? Browse other questions tagged .