2

I recently got a new LG G2 from T-Mobile and it worked perfectly fine but now When ever I plug in my headphones it randomly opens Google Now. It always says "speak to search" or it turns the music or what ever I am listening to maximum volume. And when my device is locked with my password it just repeats "Please unlock the device". Can someone help me?

1

Are you using the headphones that came with the phone? If not that could be why.

Even if they're genuine Apple EarPods or Beats - it looks as though the main issue is the middle button in the headphone is stuck while pressed in.

| improve this answer | |
1

SO this has to do with the 3.5mm audio port on thje device.

With special headphones (the ones with controls on the wire) this feature gives you the ability to voice search without taking out the device. but for you (and me) it just bugs out.

basically the male headphone port is brushing up against the designated special area on the female port (top kek) and giving it the signal to do whatever (google now, modify volume, ect)

You cant fix it as of now, but if the device is in sleep mode or whatever google now wont open, and powerAmp has an option to disable volume modification.

and thats about it.

| improve this answer | |
  • I don't understand how every one is saying this is a headphone jack issue. I've more than 50 apps installed on my phone, some of them with microphone permission too, yet none of them opens when headphone is connected. The problem exists only with Google Assistant/Now app. – DroidHeaven Apr 1 '19 at 6:31
0

I used Titanium Backup to freeze the Google app responsible for Google voice search (I don't use it). Now everything is back to normal again, like I expect it too.

| improve this answer | |
  • Please take the tour of this site. This is not a forum or any discussion platform which means no ranting is allowed. If you have any problem with Android or Google, contact AOSP or Google team. For the time being I've removed fluff and left only the crux. – Firelord Sep 12 '15 at 14:39
0

Go to Settings->Installed Apps. Find Google Now app or Google app (whichever one is annoying you). Either disable the app or deny the microphone permission. Thats it.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.