0

I'm a recent convert to Android (I have a Moto X on AT&T) and I'm running into a problem that I never had with my iPhones: the button on my headset sometimes works; sometimes doesn't. It upsets me greatly, especially since I recently purchased a $300 set of Bose headphones (Quietcomfort 20) that are specifically made for Android devices. I've even tried three apps from the Google Play store that purport to make the inline control work—none of them do, however. Why is this happening and, more importantly, how can I fix this?

07/30/2014 EDIT:
So I've been using this Moto X plus QC20 headphones for several months now, using the recommended Klipsch Control app to allow the button on the QC20 to work better. Well, it only seems to work about 50% of the time.

I have yet to figure out what is causing the interference, but some days, the button works perfectly. Other days, it will work, but it may take anywhere from 0 to 15 seconds before a button press is actually registered by the Klipsch Control app. It just seems to be completely random. Still other days, the button doesn't work at all.

It might have something to do with either the time of day and/or when the headphones are plugged in / removed. For example, one morning, it'll work fine. Then I unplug the headphones and go to lunch. Returning from lunch, I plug the headphones back in and the button no longer works. Or the reverse could be true: The button doesn't work before lunch, but works great after.

Because of this odd behavior, I'm sure you can see why I am fearful of unplugging the headphones for the rest of the day once the button on them starts working. I know that if I unplug them and plug them back in later, I only have a 50% chance of the button working.

I hope this makes sense. More importantly, I hope someone can see some sort of pattern that I have yet to see in this behavior to identify the cause(s) of this problem. Any ideas?

  • Try the Klipsch Control app. It works for any headphones and has a couple features most other apps don't: it'll check for conflicting apps and will allow you to control the just one or most recently used media app with the button. Also check to see if any of your media apps have their own headset settings (especially Player Pro). Finally, Android only supports one-button headset controls. If you have a 3-button, only one will work. – P Fitz Mar 26 '14 at 23:53
  • Thank you for the suggestion, P Fitz. I had already tried three other "remote control" apps without success, so I wasn't looking for any others. Nevertheless, it seems your Klipsch app is working for now. I just hope it actually deals with the underlying problem of the controls not always working. Also, I knew about the one-button limitation, which is why I purchased the QuietComfort 20 set, which is designed for Android (has only one button), and not the QuietComfort 20i set, which has three buttons for Apple devices. – Sturm Mar 31 '14 at 16:56
  • Oh, and even with the Klipsch app, my button stopped working again just now. But it'll probably start working again in a couple of hours. – Sturm Mar 31 '14 at 18:39
  • What music player app are you using? Many of the full-featured music-player apps have headset control override settings you may need to turn off. – P Fitz Mar 31 '14 at 19:44
  • Just using the built-in Google Play Music app. I don't think I even have any other music apps. – Sturm Mar 31 '14 at 19:48
2

I have a moto X also and I recently bought the QC20.

Commands with main button did not work (neither did the micro btw) so I installed Klitch Control and still it did not work.

Then, I looked around and changed the audio settings. I turned the audio effects off, and then it started working... (why? don't know) I uninstalled Klitch Control and it's still working. I've even put the audio effects back on and the button still works..

Hope this helps.

EDIT 05/09

Hey guys, it stopped working almost directly. Today I took care of it, and I finally managed to have something working (and free): headset button controllerTrial APP. It fixed everything : micro OK, switch OK, only thing you can't change is the long press action which is reserved on Android phones for google now..

Enjoy your QC20!

  • Thanks, @loic. I'll give that a try over the next several days and see if that seems to take care of it, then accept this as the correct answer if it does. :~) – Sturm Aug 21 '14 at 20:59
  • The headset button controller app allows to direct the headset clicks to any other app that supports it. It has some bugs BTW. – P5Coder Feb 14 '18 at 10:11
0

If you press the buttons exactly the same way (maybe iPhone buttons send shorter/longer signals than Android ones) and the pins are connected the same way (maybe not), then perhaps your wire is defective. See whether it stops working if you bend or twist the wire a certain way.

  • Again, I did not purchase the version of the headphones for iPhone. I intentionally purchased the QuietComfort 20 set, which is designed specifically for Android, BlackBerry, and Windows phones. The only answer, then, is that, as you say, the wire might be defective. I doubt it only because once the button works, it will continue to work, so long as the headphones are plugged in. (It's also been like this since the day I got them.) Beyond that, I just have a gut feeling that it's software-related. – Sturm Aug 8 '14 at 19:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.