0

My tablet is HKC P077A with 8GB ROM, 512 RAM and a 7'' Touch screen (Android 4.0.3). I am having 2 problems

  1. When I switch on the tab, first "HKC" logo comes to screen and then disappears to show "android". This is standard. But after that the thing wont move forward. Just keeps on showing "andriod" with a flashing like thing implying the loading process. But after long wait there is no start screen and nothing changes. It just hangs there....

  2. But if somehow got it to get into normal working(I donno how, but It sometimes boots ok and gets into normal working mode, with home screen and apps and everything). So once I get it right the other problem I am having is that the touch is giving VERY bad response. I have to click at spots multiple times to select that thing. Also the response is very slow. Its like the tablet is hanged. But when I tried connecting a mouse (through OTG) and everything works fine again. Is my touchscreen gone bad..??

I am already done with, reset (from "settings> backup and reset") [I cant find how to do factory reset on this model from "off" state(read below)]

I have tried to get into reset screen by pushing "Power Button+Vol up" button. Then I know the tab gets turned on (I can hear a small white noise from the loudspeaker) but nothing comes to screen. So the "Robot with heart open" is never shown. I also tried using "power button + Volume down", this takes me to a screen written in chinese. Now, I don't know Chinese but from the look and feel, its a troubleshooting window, where I can check weather components of my tablet are working (eg. I click one menu(with difficulty), then the front cam turns on, another menu makes loud sounds from speaker and another flashes many colors in screen etc). I found that most are ok except something called "T" (On the screen, its the last item to the right, is it "touchscreen"??)

So, what can I do to get my tab to work smooth again..? Is the touchpad having trouble..? Need I do any specific troubleshooting..?? Any Ideas on which key combinations to get on to the "factory reset" menu from off state..??

Now, I seems I have lost the ability to boot into Android. So I am now stuck on "problem 1(above)"

  • Sounds like normal behaviour for a cheap Chinese Android tablet... – user5506 Mar 27 '14 at 8:40
  • Anybody please.....Is this time to dumb the thing...?? – qzyDO Mar 31 '14 at 10:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.