0

I searched lot on google but I didn't find any working solution to stop receving messages from "50"

I tried these solution but didn't work for me - Is there no option to turn off cell broadcasting messages in HTC Desire 500?

Does anyone really have a proper solution (have experienced).

Also please dont mark this question as duplicate.

  • Could you edit your question and add what version of android your device runs. Some of the settings may be dependant on the version of android. – Ryan Conrad Dec 26 '14 at 16:03
  • Also check this question and see if it helps your issue at all. – Ryan Conrad Dec 26 '14 at 16:06
1

Yes. Just remove the SIM from the phone. In the message settings of phone, it will show as disabled.

Restart the phone, and check and uncheck cell broadcast settings. Then insert the SIM in your phone. It worked for my phone, so hopefully it will work for yours as well.

|improve this answer|||||
1

Please open your stock "messaging" app --> go to settings inside messaging app --> scroll down and you should have "cell broadcast settings" option. Click on that and there uncheck the option provided.

Hope this solves your problem.

|improve this answer|||||
  • Sam there is no setting option in messaging – railsbox Apr 30 '14 at 9:02
  • After opening the messaging app please tap ":" (three vertical dots) on right hand top corner of your screen and you should be able to go inside "settings" and then you can turn off the "cell broadcast settings". – Sam Apr 30 '14 at 9:15
  • there is setting option but no cell broadcast – railsbox Apr 30 '14 at 9:20
  • Setting->call->cell broadcast->uncheck it .. Please try this. – Sam Apr 30 '14 at 9:23
  • i chat with HTC Customer Care Executive they repiled me there is no option for cell broadcast in HTC Dual SIM Phone :-( – railsbox Apr 30 '14 at 9:30
0

Setting->call->cell broadcast->uncheck it (Surely can stop Cell info display in HTC ONE M8 by this way)

|improve this answer|||||
  • This will also disable important cell broadcasts in case of emergency. Just keep that in mind. – GiantTree Jan 4 '15 at 16:05
0

I have an HTC 10 and someone just told me this was happening from me to them. This is how I fixed it (oddly, no one else told me they get this odd CB# thing). CB is cell broadcasting or in my case, CALLBACK. Go into your mssging, then the 3 dots (settings), go to GENERAL. Scroll down to the bottom. I DIDNT have CELL BROADCAST, I had CALLBACK.
Remove the checkmarks out of Callback Number for SMS and Callback Number for MMS. This should resolve the issue for YOU sending the callback to someone else. I verified with my person that Im not sending her the callback line anymore. I cannot find a setting if someone is sending it to you. THEY would need to fix on their own phone. If you don't know the person texting you, I suggest you BLOCK them.

|improve this answer|||||
0

I finally managed to solve it.

Go to default messaging app -> goto Settings -> select Cell Broadcast. Suppose, if everything is off, but you still get messages, then, go to Customized Channels and add channel 50 (the one that serves me annoying messages). It will be enabled default. Click on it again, and set it to disabled to block the channel. That is it.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.